"Splash: recv failed" - Java Web Start client problems

I have found this thread here and I couldn’t post to it (must be closed or something):


My son tries to login to an Online Classroom for a course he is taking, and it runs using a java download.
When the classroom tries to load we get this message:
Splash: recv failed

I am surprise Comodo hasn’t address this yet as the above link is an old thread.

putting it in “Training Mode” seems to be Very erratic. Sometimes it works and sometimes it doesn’t.

The only way I could ‘guarantee’ that it would work is to fully uninstall Comodo (very disappointing).

Can anyone offer additional assistance with this?


I won’t bump this repeatedly, but any help on this would be appreciated. Thanks

I’ll move this post to a help forum where it may get more visibility.

I’m also getting the same problem with the 5.8 beta. Trying to execute an online class java application causes this issue to occur.

I’ll bump this one. This is major problem and it is widely known across the Internet community. Comodo should do something about it! The problem continues even in version 5.9.

Can you provide any examples of sites where this is happening please. I tried the site listed in the first post and it works correctly.

[attachment deleted by admin]

The same problem with Java when trying to launch application at Field Controller with Web Server, only one solution, full uninstall Comodo CIS. I was very disapoited after several years with COMODO.

can you provide some more details please.

I have this problem as well, from


I’ve tried disabling each service individually and all of them as a group, and I can’t figure it out. I’ve manually added a trusted rule for every .exe file in the \Program Files (x86)\Java\jre6\bin folder. Nothing works.

This is causing me to reconsider Comodo as my endpoint protection. Any help will be greatly appreciated.

(That’s a private site, but it requires a login to function so I wouldn’t be braking any rules by emailing the .jnlp file to a technician.)

Can you show me a screenshot of the D+ logs of around the time the application gets started?

Try adding the Java installation folder to the Exclusions of Detect shellcode injections (i.e. Buffer overflow protection) and see if that makes a difference or not.


I have the same problem.
I’m receiving this error when I’m trying to open java based KVM web console to cisco servers.
Trying disabling D+ or adding exclusions to Java folders does not help.
In my case it helps disabling the firewall, but when it’s active and the problem happens, I do not see any events in FW logs.
Please let me know how can I help to resolve the problem, because this is the only thing I do not like in comodo.

Unfortunately, I don’t have anything Cisco to test, but all of these “Splash: recv failed” problems are due to incorrect firewall rules. There’s a similar thread, in which I posted an answer, here Likewise, the answer to the problem posted by MOster - a couple of posts above - is similar. See images.

[attachment deleted by admin]

Thanks for helping.
I found what rules needs to be set up for this to make it work (the connection scenario in my case)

  1. C:\Program files(x86)\Java\jre6\bin\javaws.exe makes a TCP connection from IP to (random ports)
  2. C:\Program files(x86)\Java\jre6\bin\javaw.exe makes a TCP connection from local IP address (random port) to remote destination (HTTPS - 443 port)
  3. C:\Program files(x86)\Java\jre6\bin\javaw.exe makes a TCP connection from local IP address (random port) to remote destination (2068 port)
  4. C:\Program files(x86)\Java\jre6\bin\javaw.exe makes a TCP connection from local (random port) to (random port)

The only interesting thing that I can’t understand is - why these blocked connections by comodo are not shown in the logs?

If you receive an alert from the firewall, there should be a corresponding log entry. What are you using for the firewall behaviour settings?

[attachment deleted by admin]

This is the problem - there are no alerts from FW it just blocks the program internally without any logs.
If there were some alerts - great, I would see what is trying to connect where and no problems.
The way I found out what is trying to connect where - I created an allow all rule with logging from it - i saw what exactly was trying to connect where.

Without seeing your configuration it’s difficult to say. Please post details of your firewall behaviour settings.

My firewall is running in safe mode.
From general settings I have selected:
Automatic detect new private networks, Show trustconnect alerts for public networks, show traffic animation in the try.
My alert settings are:
Alert Frequency level - low and all the check-boxes are selected.
Under advanced - nothing is checked.
My version is: 5.9.221665.2197.

P.S. if the FW would ask to allow or deny these java applications - there would not be any posts here in the forum.

Unfortunately, the lack of alerts and consequential lack of log entries, is a by-product of running a ‘safe’ application in ‘safe’ mode. The general idea being, people don’t want to see alerts, more than they have to. That aside. the connection should still have worked, as the type of rule created - you could have actually seen the automatically created rule, if you’d placed a check in the box for ‘Create rules for safe applications’ - is generic (image).

In a nutshell, if you want to have control over the rules used in the firewall, at the least, check the aforementioned box, better still, use custom policy mode. Yes, you will get some alerts, but with alert frequency settings set to ‘low’, you should only see the alert the first time an unknown application is run.

[attachment deleted by admin]

OK, clear, thank you!

Just wanted to throw this in here as well.

I received this error when trying to launch a Java application. Nothing in the logs, no alerts from comodo.

However, Comodo is in “disabled” mode. What gives?

I am now going to uninstall this awesome tool. Maybe I’ll try it again at a later point once all the bugs are worked out :wink: