Spelling check doesn't work in V68 again

I have created a thread re previuos version’s spelling check . No one replied. In the 67 that problem seems was fixed. This problem is on again. Version 68. I am writing email within CD and the spelling checker doesn’t work, but turned on for sure.
Anyone will reply when this bug will be fixed permanently?

Older post:

Hello Compugrid.

I am not sure if the spell check issue is a bug or not, but I have had the same problem intermittently when a Comodo Dragon update is installed.
The developers may have more insight regarding a permanent fix.

This is how I fixed the issue:
I tried all kinds of fixes that were listed by various on-line sources (most of the fixes were listed for chromium or chrome browsers), but the only fix that worked for me was un-installing comodo dragon, and doing a fresh re-install.
I had to re-install all of my extensions (such as Adblock).
I exported my bookmarks just in case they got erased, but for me, the bookmarks remained despite uninstalling Dragon.

Re-installing has solved the problem for me both times the spell checker stopped working.

Hi Cave,
Thanks a lot for the reply. For the last few month you are the only one who has written something regarding the issue.
Thanks for the suggestion. Have you reported the bug to support? I would if I know how.
Although reinstalling most likely will solve the problem it seems ridiculous to reinstall the app after each update. I should have stayed within the 67 version of the CD , which has had no spelling check problem.
MY CD opens 8 windows , each window opens multiple tabs. there are up to 40 tabs in my CD in total. I am afraid to lose them even after backing up the session.
I will wait for the next update hopping someone from the technical CD support will read our posts. Thanks


Hello Compugrid and sorry for the late reply,
The spellchecking feature in Dragon is disabled from v65 because from that point on it became a Google owned service that uses servers for spellchecking - Comodo Dragon is made for users privacy so we won’t use that service. From Dragon v66 we started implementing our own spellchecker that uses local dictionaries like it used to work until v64 and it was fully working in v67. It seems that the spellchecker that worked for those versions is not working for all our users on V68, and we thank you this way for reporting the issue. We are currently working on a fix for this problem and by the start of the next week we will release a hotfix for Dragon v68 that will fix the spellchecker problems and other issues.
Thank you !
Alex, Comodo Browsers Team

Yes you are right it worked in v67 and before v64. Is it will be constant issue with new versions or will be eventually fixed permanently? Should i keep older version in the future while the spelling checker works? Thanks for the reply. I was glad to receive it. I am waiting for the fix next week.

Can you please check if it’s working now? We changed the dictionary files on our servers and we need to know if this fixed the issue for all our users.

Nope , it doesn’t. Shouldn’t i get an update pop up? Restarted CD , but no luck.

We only updated the dictionary files, not the browser. It should redownload the dictionary when you are on a webpage were the spell checker has text to modify. Please go to HTML 5 <textarea> Tag and write anything in that text box and see if it starts to autocorect. And please send some webpage examples that don’t work.

I just tested in your page provided by you. it doesn’t work
see the attached screen shot . Even typing here doesn’t get spelling check. Using the web based emails like hotmail , mail.com or msn or any other ones donot work either. But did work before in v 67.
here is the text :
thisss iss a tesst for spilingo wichss das nut wurksss
I see no spelling on it . the same in the attachment.

Can i restore to v67 without reinstalling CD?

Hi compugrid! Thank you for the feedback.

You can downgrade to version 67 by accessing the setup for version 67 and select Downgrade to 67.0.3396.99 (see attached screenshot).
If you do not have the setup for version 67 you can download it here Download Comodo Dragon 104.0.5112.81 for Windows - Filehippo.com
Can you also provide more information about operating system, AV or add-ons because we can not reproduce that issue anymore?

[i]Thank you very much,

The Comodo Browsers team[/i]

Win 10 Pro ( updated current), no ad ons, AV- Bitdeffender Int security. Just to mention spelling works in Firefox , Opera and IE

I reckon this might help : I just went in about CD it says : A new version of Comodo Dragon is available
Version 68.0.3440.106 (Portable Edition) (32-bit). My current version is 68.0.3340. The point is it is PORTABLE!

just tested the new 68.0.4440 version. the problem is current, not fixed. Rolling back to 67

Comodo Dragon
Comodo Dragon is up to date
Version 68.0.3440.107 (Portable Edition) (32-bit)
What do you want me to do? There is no screen saying to roll back. It is just want to reinstall it to 67.
Also noticed my portable is in the Program files (x86). the installer wants me to reinstall it into the folder Program files. Don’t see how is the folder structure can influence on the spelling check.

Installed v67 64 bit portable into the same folder i’ve had the portable x32 version. Spelling check doesn’t work.

Updated v67 64but to v68 64bit. Still spelling doesn’t work. You might say it is individual. I’d say the guy above has had the same problem. There are a few already. BTW when i say spelling check i mean the automatic words underlining with red if the spelling is wrong.