sonos desktop controller firewall blocking


I don’t know why after adding sonos as a trusted application, the firewall is still blocking the application from working.

please see image:

I know it’s the firewall because when I switch it from SAFE MODE to DISABLED. The sonos application connects fine.

However, when i turn the firewall back to SAFE MODE, the sonos application cannot connect.

The way I added it is by finding running processes, and selecting sonos.exe

Sonos used to show on Network Intrusions but is no longer the case after I added it as a trusted file and trusted application.

Please help!!

Thank you very much



Thank you for your reply.

I looked at the page you posted and basically it’s saying it’s possible some ports are being blocked.


I made a rule for it allows any TCP or UDP connects to be allowed. Please see image:

Unfortunately, sonos still cannot connect…

Any other ideas?

Thank you for your help!

  • Remove rule
  • Choose authorize firewall
  • Search for the program to allow
  • OK
  • Restart PC
  • Program Launch

thank you for your reply

did everything as per above and here is the screenshot now:

unfortunately, sonos still cannot connect :frowning:

i wonder what part of comodo is still blocking it…

Launch the program
Check inputs and outputs on the firewall
Deduce matches

Install KillSwitch to check the inputs and outputs
Deduce results

Vuze example

thanks! here are the results:

what does that mean?

The connections are established for the program sonos.exe (
This IP address is simply used by SSDP (Simple Service Discovery Protocol) which allows to discover network services or presence information. SSDP is the basis of the discovery protocol Universal Plug and Play (UPnP) and is intended for use in office or residential environments. SSDP uses the User Datagram Protocol (UDP) as the transport protocol. The services are advertised by the hosting system to a multicast IP address specifically designated on the port number 1900 / UDP. IPv4, the multicast address is the famous

the networks must be sought from the PC and deduct blocking
Wifi- Ethernet ?
To allocate the settings CIS

Try turning off block fragmented IP traffic, it could be possible that the application is trying to sent packets larger than the MTU on the given connection link and comodo blocks these types of packets even if a rule to allow communication.

thanks for the suggestion. i think for me, the block fragmented IP traffic was off before.

here is the pic

From Reply # 7

  • Disable the firewall
  • Check the operation of sonos.exe systems
  • Capturing the connections as to the answer # 7
  • Confirm the data exchanged <=>
    return on-screen images
    Activate Firewall
    Thank you

thanks for the reply.

the list is very long so it has two be 2 separate screenshots. also, and are not on the list.

In the Firewall Training Mode select
start sonos.exe
Message from the firewall back ?

sonos.ex it is accompanied by a device connected to the PC ?

training mode, please see attached

the device (speaker) is not connected to the PC

The learning method has no return window
Related sonos.exe ?
It seems that the problem is > UDP
Thank you to try this rule
Reboot PC

Home#1 is >

For information:

When configuring your firewall, be sure to look for pre-defined rules that could be blocking the ports Sonos uses.
Below are the ports that Sonos uses:

80 (Internet Radio, updates and registration)
443 (Rhapsody, Napster, and SiriusXM)
445 (CIFS)
3400 (incoming UPnP events - Sonos Controller App for Mac or PC)
3401 (Sonos Controller App for iOS)
3445 (OS X File Sharing)
3500 (Sonos Controller App for Android)
4070 (Spotify incoming events)
4444 (Sonos update process)

136-139 (NetBIOS)
1900 (UPnP events and device detection)
1901 (UPnP responses)
2869, 10243, 10280-10284 (Windows Media Player NSS)
6969 (Initial configuration)

Note: When configuring a software firewall, the above ports will require inbound access.

Are you trying to receive a connection from a device on the network? If so then in addition to an application rule to allow inbound access, you also need to create a global rule to allow the incoming connections.

question => answer:;msg843921#msg843921

sorry for the delay… i’m having trouble doing and will need to use google translate to figure out the screenshots tomorrow

in the mean time, can you let me know the difference between the rule above V.S. allowing ALL connections?