Sometimes CPF does NOT work (after logoff-logon) [Resolved]

I let you judge of the seriousness of the situation … >:( >:(

I needed to logoff/logon, when I come back, CPF is totally deactivated !
Tray icon is gone, and when I run the app, and click on “ON” to reactivate app protection, it simply doesnt respond.

I guess I will try to restart the service or reboot but I mean …
Yes CPF does work with some glitches, but here? ??? ??? ???

PS not even mentionning some apps in the “connections” section whilst these apps are not even running!!!

– edit —
Tried to restart the service, guess what, take a look at the attachment …
I suppose a reboot is necesary (:AGY) (:AGY)

[attachment deleted by admin]

Hi,

You’re not the only one with such a problem: https://forums.comodo.com/index.php/topic,6389.0.html

However, I have not heard anything after I was told that “if we can replicate the problem, we will create fix for it”. I truly hope that they were (are?) able to replicate this problem, and will fix it ASAP…

  • mode off topic ON -

Well I can see the qualities of CPF, I trully do since I decided to switch from Kerio but there are some glitches which are really a pain, such as this, and repeated questions about some apps asking for permission when I already autorized them!

CPD needs to step up, I dont see how a “non computer savvy” can manage this type of issues

  • mode on topic ON - :o

Dear Placoboy,

am I mistaken or are you running Vista OS?
I can see it by background of pics you pasted in your post.
Well, if you want to use Comodo F. P. along with Vista,
you’ll have to wait for CFP version 3.
Am I wrong?

Stay tuned
Nicola

Good eye, Nicola ;). However, I can tell that placoboy is not in fact running Vista for two reasons:

  1. The titlebar of CFP is black in that screenshot. Vista is light blue if I’m not mistaken. There are utilities out there that can mimic Vista theme style (I’m using part of it through a patched theme)
  2. placoboy has been running CFP for some time now and only recently did this issue manifested, in a specific environment of logging on/off.

The logon/logoff fix (along with Vista and X64 support) is slated to be introduced in version 3 of the firewall. The logon/logoff fix may not make it into the first cut of the beta (due April 16),but Comodo have been able to reproduce the error and have committed to a solution.

Cheers,
Ewen :slight_smile:

Yes. According to user RichZ, Comodo has identified the issue.

All of this fixed (:CLP) good to know. I am sure CPF is on the right track. It just frustrating some time to have to deal with a product which brings some “bug” too often.
But dev team seems "committed "so thats fine. Thanks and I will be wiating for Apr 16th !!!

PS and yes btw I am not using Vista ;D ;D just a skin with StyleXP :wink:

BTW please let CPF really memorize some rules, it seems we have to authorize apps that have already been authorized … sorry off topic but, I feel better now ;D ;D

I knew it! :D. placoboy, have a look at this: https://forums.comodo.com/index.php/topic,6908.0.html.

In the meantime, instead of a reboot I think a restart of CFP could work.

Thanks for the feedback

  1. impossible to restart CPF it becomes unresponsive both at app level and also at servicelevel where I could not restart it, I rebooted and we are back in business

  2. as far ar as multiple request from CPF are concerned, well I see your point related to rules with a different parent and so on, on this I am fine. It still does not address the issue of multiple requests with apps authorized, there seems to be some interconnection between apps such as for instance when gmail notifier tries to reach the internet and there was “some previous” action from Thunderbird (for instance), I get a popup from CPF asking me to authorize GMail notifier (already authorized) but being “OLEd” by Thunderbird ?!?!?! this is the kind of thing I have a hard time understanding.
    And it does not occur all the time but only in special circumstances …

placoboy, your alerts is a different issue. You can continue that here.

Soyabeaner, thank you for your explanatory paragraphs.

I didn’t know there were such a Vista skin possibilities… 88)

Have a nice day,

greetings from a sunny Italy

Nicola

Yes you can :wink: http://www.softpedia.com/get/System/OS-Enhancements/Vista-Transformation-Pack.shtml

ps. Sunny? It is 11 pm in Italy at this moment :stuck_out_tongue: 88)

30.2 MB for VTP? What a rip. CFP is almost half that size!

I didn’t realize Italy was big enough to surround the equator :o

OK I’m going to lock this thread as resolved because we know CFP 3 will have a fix and before it gets any weirder. :stuck_out_tongue: