Sometimes Comodo Internet Security consume hight CPU

more than one time Comodo start to use hight CPU and made fan on my PC run very fast. Only solution is reboot the PC.

If this issue persist I need remove CIS and use another software. Now I have the issue so I need remove CSI or I will se gain and again this sisue. Last time was two day ago.
This can damage the PC hardware also.

The version is

Which process was causing the high usage? cmdagnet or cavwp? Do you have create rules for safe applications enabled in HIPS or firewall settings?

I do not know what process just take the screenshot.
As this issue is not new and has been repeated as the PC is always on and sometimes I am not a the PC, as this is a very urgent issue and can create damage I uninstalled Comodo.

Installed again now all is working but issue still exist. It’s not normal that Comodo made CPU 100, 95 % without have a sensor for understand it are causing hardware issue.

Do you have create rules for safe applications enabled in HIPS or firewall settings?
I do not insert custom rules. all is done by Comodo. I never enter in the settings.

Issue can’t be investigated or fixed without it being properly reported with the necessary information. You should then use killswitch to see the process using high cpu and provide dumps of the process using create dump context menu. You can install killswitch by running the watch activity task.

I will see if the problem will occur again.
In all case was not happy to discover the program that cause CPU issue and made fan of PC work very fast.

I will try to update you again if the issue will occur again.

The issue come again today.
The process who cause CPU issue seems to be cavwp.exe

Restart this service seems to solve the issue but the issue is not solved as seems Comodo are ready to kill my PC sometime by using hight CPU and by madding fans run fast.

Seems the issue with this file is not new:

I have one SSD hard disk and one "normal " SATA hard disk.

The mentioned process use hight CPU sometimes and made the PC to run very fast fans.
This is a very important issue and cannot trust Comodo Internet Security if cause this issue randoom to my PC some day.

I hope to hear you soon with a solution. Maybe I will use another software for now for protect my PC if this issue will be not fixed.

Hi Peopleinside,

Sorry for the inconvenience caused. Please follow this step when high CPU is noticed.

Can you please go to “Task Manager–>Details” tab and select cavwp.exe and take 3 dumps via right click option on process and selecting “Create dump file” and share via some online drive.

Thanks in advance.

Kind Regards,

Sorry but this not work. You can create two type of dump, every option I try give errors.
Operation failed

So now?

I removed Comodo and I AM now using a different program.
I hope Comodo will fix this issue so I can go back to Comodo Security.

If I am not wrong your website say your program monitor processes and do action if process create issue on the PC. Is pretty strange is a Comodo process to cause PC damage and issue.
The process indicated in the previous post made the CPU to be used also at 100% , fans of the PC are runniong very fast and what happen if you are not on the PC and your PC stay on for many hours?

It’s not a small issue this let me think Comodo are not monitoring process and are not do action for protect the PC if a process take the CPU 100% and the crazy think is that is Comodo who create this damage.

As today the issue start to be present again I tried to create the dump file but seems is not possible for this particular process. Today also restart of this service was not possible because of access denied.

I was able to create dump file of other process but not the one is causing issue.
So i asked help on GekBuddy chat but Fred not only has not helped me but also start to close all chat.
Seems today only Fred was responding on Gekbuddy, not good support.

So I will not keep my PC with Comodo who can cause issue when i am not at PC and causing damage to hardware.
My PC is not old !!!

If I can help in some way let me know, for now I will use a different software for protect my PC, very sad about this but I need keep the P safe.

In the image attached you can see Comodo is using 92 % of CPU. Sorry the CPU line was cropped but 92 is the CPU used by Comodo.

Nothing, I need stay with Comodo… i feel no safe with other program.
Hope to receive a solution from you… I want this issue can reach Comodo and be solved.

It looks like you are running a schedule scan, you can change some of the scan options to help reduce CPU usage, such as turn off heuristic scanning, disable decompress and scan compressed files, and change the scan priority to low or background under ‘run this can with’ setting. To collect dumps from killswitch you need to force it to run as an administrator by clicking the UAC shield icon in the lower right corner next to the displayed killswitch version.

No I think is not this also if is Comodo should show a different icon if is running schedule scan.
I never see CPU 100 % when Comodo is scanning.

It’s also no possible the issue happen every 3 day or less.

Use open task manger from advanced tasks section of CIS when you see high cpu as it will list the running tasks such as a scheduled virus scan. In your last post of showing two instances of cavwp.exe one is the real-time scanner the other one is most likely a scheduled scan that you have configured. To collect dumps from killswitch you need to force it to run as an administrator by clicking the UAC shield icon in the lower right corner next to the displayed killswitch version.

I will check thanks. Anyway if a schedule scan is done is the default one so why is not limited by default to use lower CPU? I do not have customized scheduled scan. Happy is active by defualt but should not take CPU at 92 % also because my Desktop PC is powerful.

Hi, thank you for your help!
Seems you are completely right, the fan and CPU issue seems to be caused from a schedule scan. Schedule scan is very important so i do not suggest to not have scheduled by default. I tried to change the priority to background is little bit better.

I continue to think that Comodo icon on the try should change for inform that is running a scan. I saw this usggestion to be made in the past but not yet implemented.
Thanks also for the very useful message here:

I edited the scheduled scan.
The full scan to be done not once a week but once a month and of curse on background. It takes more than one hours for end maybe two hours and fan speed increase.

I edited the fast scan to be done once week instead never.


Prepare yourselves for I have a workaround to your problems whether it be High CPU or High Disk usage.

Just go into your windows 10 compatibility assistant and set Comodo internet security to compatibility for windows 8
and watch as all your problems magically disappear… Took me forever to figure it out but it worked on two different
computers I was having the same problem with… I gave it the preliminary 3 hours to see if the problem would come back
but so far everything seems to be holding steady. Hope this works for you gents… Cheers…