Sometimes antivirus scanner gets stuck on one file

I have had this happen twice now. I would run a manual scan and the scanner would get stuck on a particular file. It would just keep scanning that file. when this happens i can’t cancel the scan. I hit cancel but it just keeps scanning. I have to reboot the computer. Each time it happened it got stuck on a different file. This only happened twice. All other scans finished without an issue. However, i have only been using comodo anti-virus for a few days.

I am having the same issue, the scan freezes on different files and then you can’t stop the scan without turning off the puter. I changed the DEP setting and it didn’t help. No one on here seems to be able to help with this issue.
Dennis

Hi Viper & hakunamatata,
I also faced the similar problem with old versions, but now with latest version 3.10.xxxx.531 fixed it for me, so please are you using latest version of CIS (3.10.xxxxx.531) which has lot of improvements.

Yep that is the version I am using. Mine seems to stick on the System volume Information file. The status line just flickers. Total objects scanned stops at 358146.

I am also having the same problem. See my message sent a few mins ago Subject: CISPro runs virus check for over 12 hours???

Has anyone come up with an answer? Anything common on all our computers, i.e. which spyware program are you running if any? I am running PC Tools SpyWare Doctor.

I am running Comodo BOClean anti malware.
Dennis

I have never had a problem scanning with Comodo AV until today and mine stuck on this exact same file. Like all the previous posters I had to crash start my PC to get everything to work again. On reboot I went through Comodo checking to see that everything was working etc and noticed while clicking on the “Update Now” AV button that an update from 1724 to 1725 was available and updated.
Maybe some of the mods could tell what effect an automatic update would have on the AV if one became available during mid scan although i still find it strange that my PC and Hakunamatata’s both stuck on the same file. Anyone got any ideas what would cause this to happen?.

If you are running CIS, the functionality of BO Clean is now incorporated. There is no reason to run the standalone version.

I reinstalled Comodo and then did a scan and found 3 trojans in the system volume file. The scan finished with no problems. Try a reinstall.

I’m getting this problem, stuck on the 95th file after 1h30mins. When I try to pause, stop or start a scan, I get this error:

Update failed. Error code 0x800705aa. Insufficient system ressources exist to complete the requested service.

Possible related errors in Event Viewer is ‘An unhandled win32 exception occurred in cmdagent.exe [924]’ by VsJITDebugger.

Closed CIS then restarted it. ATM it’s hanged on ‘COMODO Internet Security is being initialized…’

Running Windows XP x64 Pro and CIS v3.10.10x~, no other antiviruses, running a2free.

Before you ask, I don’t see any problem with my system ressources (hard drives not full) unless it is talking about software ressources.

http://img228.imageshack.us/img228/8881/sysrescisscan.png

Same problem.

Try to pin-point the trouble area with the context-menu scanner by scanning root folder by folder

\Documents and Settings
\Program Files
\Windows

etc, now in the folder that fails try to isolate the folder beneath that where it fails.
If you can reproduce and know on what files and or folder it fails, please report back… It will help the Dev’s to know what goes wrong, also please post the windows eventlog crash info from cavscan.exe or cmdagent.exe

You can also use Process Explorer and Process Monitor to watch cavscan.exe do it’s job, on process monitor you could filter on cavscan.exe and only show file monitor activity to see in what file and or folder it last accessed.

The cmdagent crashes with error code (?) 928 when scanning the file ‘C:\Program Files (x86)\Xfire\xfire_toucan64_37857.xll’ (always this file). I’ve been running XFire for 4 years with many antiviruses, like Norton, NOD32, AVG and lately avast, and now Comodo, and had never had any problems with scanning it’s files.

The event error is a typical JIT crash, it is called by cmdagent.exe and handled by JIT. It happens the moment the scanner attempts to scan the file.


http://img521.imageshack.us/img521/5787/comodoscanerror.png

Here is a link to the file if you want to attempt to recreate the error.

I appreciate your concern and I hope that this issue can be resolved promptly.

PS: I did not notice any cmdscan.exe process, only cmdagent.exe.

It happened to me to too it stuck on a jpg image file. the error was the same as Tase’s. after that i run diagnostics and it found problems in the installation and it asked me to reboot. after the reboot the error reporting tool of the windows came up verifying the diagnostics. Could it be something in the update that it does before the scan?

My scans freeze on the same file :/Windows/System32/guard64.dll and I have to reboot. Any suggestions are welcome.

I have exactly the same problem, with the scan stopping at guard64.dll. Only a reboot helps. Guard64.dll is a Commodo file, so an update on how to fix this would be welcome.

Can you put this file on the AV exclusion list and see if the scan finishes then ?

I have now put it on the anti-virus exclusion list. Instead of excluding it from the scan, it now starts with Guard64.dll, and then locks up. It used to scan 58 files before stopping. :cry:

EDIT: Part of the mystery is resolved, if not the problem. I added the “Commodo files” to the exclusion list, which excludes “C:\Windows\System32\guard64.dll” among other things. This is obviously scanned first, so excluding this took away the first 57 objects to be scanned. When this did not help I added “C:\Windows\system32\guard64.dll” to the list (manually, note the lower case on system32), this made made it skip the file where it crashed. The scan proceeded very slowly to a random file and crashed again. This was object number 328, and it took about a minute to get there.

That it starts with guard64 is because memory scanning is active, can you untick that from a manual scan ?
It will first scan all drivers etc loaded in memory and guard64 is part of that in memory scan…

I assume you reboot after it crashes because when it crashes the engine goes “dead” ?

I unticked the memory scan, now it crashes in at a new file. Total objects scanned: 59

This time when I tried to click “Stop Scan” It gave an error code: 0x800705aa Not enough system resources to stop the service. Stangely enough, it did shut down after that. No luck on the scanning, obviously.

It never did that before. I have had to hard reboot after Commodo locks up. I can move the mouse and continue to run any program that was already up and running, but not start any new ones, and not shut down the computer normaly.

I’m on Vista64, btw.