Something is Killing Comodo Agent Service

First I noticed upon start that my firewall was not operating but was allowing all traffic, a bad situation. Then I visited this forum and used Process Explorer to determine that Agent Service was not operating, though CPF.exe was. Sometimes upon boot all was fine but about every other time the firewall would not work. I tried reloading Agent manually with Explorer and it ran for a moment and was terminated by some unkown entity or process. I unfortunately still use AOL though I should know better, and I did just get an “upgrade” forced upon me. When I go back to P-E and kill all AOL processes the problem remains. If the solution to this is posted elsewhere and I missed it please direct me. I sure don’t want to access the internet with my firewall down half of the time. Can anyone help? Thank you in advance.

Here’s an update- I found that when I shot down the PC by hitting the PSU power switch and then start it up the firewall loads normally. When I shut down in the proper way and start up I have no firewall.

I think something went incredibly wrong during your installation of CFP; it should not act this way, no matter what…

I think it might be good to start over with CFP, in this manner:

  1. Reboot into SafeMode.
  2. Uninstall CFP via Start/All Programs/Comodo/Firewall/Uninstall
  3. Reboot into SafeMode.
  4. Clean the registry (easiest way is to use an application like RegSeeker or ccleaner) - be certain to create a backup before deleting any registry items
  5. Reboot into SafeMode.
  6. Reinstall CFP.
  7. Reboot normally.

This way you make certain that no conflicts from other applications occur during the installation, and whatever might be in the registry causing problems (if any) is cleaned out as well.

LM

Thank you for the answer so far- let me add a couple more pieces of information-

-The firewall has worked well for months and has only recently started malfunctioning.
-When I attempt to restart Agent manually from the Comodo folder it will start and run for a moment and then terminate. I watch this happen with Process Explorer.

  • There are other indications that malware may exist on my PC, though I can’t assume this contributes to my firewall problem.

Believe it or not, LM’s solution is the same that solved another member’s issue who experienced something similar with his CFP working for months until something happened recently…

https://forums.comodo.com/help/cfp_nod32_no_longer_autostartup_resolved-t12656.0.html

Adding to LM’s suggestions, you might want to do the same for other programs that auto-start up, mainly the security ones as they have a huger role on your computer.