SOME websites not displaying until I click 'allow all'?

Can someone tell me, in really simple terms, what I need to do so that half the websites I visit don’t get blocked? It seems to be anything that isn’t on port 80, by the looks of it and they are blocked in all browsers (that is, Firefox, Opera, IE) .

To test, I tried adding an allow ‘any’ rule for a particular destination port for a particular website I wanted to try and access, and asked it to log any attempts - and sure enough, it logged that it was allowing it because of that rule in the log… and blocked it anyway. Without that or any other related rule, the log doesn’t register why it’s disallowing it, so doesn’t give me a clue as to what other rule might be an issue. Though as far as I’m concerned, it can’t be one of my own rules causing the problem, because it displays exactly the same symptoms from a fresh install.

If I turn on ‘allow all’ then the problem websites displays straight away every time, so I assumed it must relate to a rule somewhere - but here’s the thing… if I have the Security level set to ‘custom’ and refresh the same problematic page, say, 10 times, it MIGHT display once. Which actually doesn’t give me a lot of faith in Comodo, to be honest. If it’s down to a rule, why would it apply only sometimes?

I was pleased to find such a fully featured free firewall solution, initially, but I have to say from my experience so far it’s just too difficult to use.

Sorry if this has been covered before, but frankly I’ve spent like two hours on this website trawling forums etc for an answer and trying various stuff to no avail, just so I can try and browse the web normally.

Welcome to the forum, jaywat.

If the ‘allow all’ works then 99% of time it’s a problem with rules, but like you experienced, it is strange why only a few sites don’t work. Couple things to start with:

  1. Please list some of these sites, so we can test them
  2. Please upload an edited (mask private IP’s) sample of your log here

Here is one for you… I just want to play a game on yahoo at this address http://get.games.yahoo.com/proddesc?gamekey=bonnie

but it didn’t like one of the files… not-a-virus:downloader.win32.popcap.b was the message. The file is popcaploader.dll

now I’m not a wizzard so this is what I tried. I tried putting Comodo in allow all, I tried going into Comodo and specifying the website as trusted and the application as allow… i went to the tools in internet explorer and added the site in the trusted section and I still can’t play it.

Overall I am GREATLY pleased with Comodo’s products but this one is a continual frustration… little quirks like this. I’ve run into this before and abandoned what I wanted to do because even though I turned off Comodo entirely the AntiVirus STILL blocked it. Also… if I have to set it to allow all to get it to let me do what I need… what good is it doing?

dvajamz, are you referring to Comodo Firewall or Anti-Virus? Because this is the Firewall board. Here’s the CAVS board: https://forums.comodo.com/index.php/board,4.0.html