Some programs won't run unless Comodo is running too

I think this happens on the D+ side of Comodo but I’m not 100% sure. I have noticed on different occasions if I have Comodo turned off, some programs are not able to run. Turn Comodo back on, and the program runs. This often happens with games. Someone mentioned on another post about running a game and D+ halts it with pop-ups. Often times you can’t Alt-Tab out of the game and even if you managed to, when you go back in some games crash. To work around this issue, I’ve disconnected from the net, shutdown Comodo completely, installed the game and then trying playing. Sometimes it works and sometimes it doesn’t. On the times it does not, I have noticed if I turn Comodo back on, the game will run. But then I run back into the problem of not being able to Alt+Tab out of the game to answer D+ pop-ups. Or if I’m able to, the game crashes.

Another example. A friend of mine was having connection issues to the net last night. He was trying to find out what item failed whether the modem, router or Vista. While he was trouble shooting, he shutdown Comodo completely. Found the issue, made changes and tried to connect to the net. He was not able to until Comodo was running. This might not be a good example because Vista might have something built-in, a safety feature since the OS was created with newbies in mind. It might not allow a connection if a firewall is not running. (OS firewall was turned off too)

A better example: Sandboxie will not run unless Comodo is running because it’s not able to start some services or initialize some components. It’s almost like the software needs permission from D+ to run and when D+ is not running to answer back, then the action gets blocked automatically.

This is very frustrating and I haven’t found a sensible way to work around it. Does anyone else have this problem? How have you worked around the issues?

See attached.

[attachment deleted by admin]

I always thought that setting was referring to apps. If an app shutsdown and there’s something still running from it - to block it. You know, an extra security feature. I should have read the explanation within the help file rather than assuming I understood its meaning. Thank you so much! :slight_smile:

You’re welcome.

And don’t feel bad about not reading the help file: most of the time I totally forget there is a help file and only think about it when it is too late. :slight_smile:

For Gaming it’s always advised to run it once in “training mode” so it won’t lockup you system/game.

Some programs don’t work on my computer.
I have instaled CIS 3.8.65… wich is update permanently.
For example firefox is not running.
I have tried to put firefox as browser or trusted aplication, but not work…
My CIS is set safe mode in firewall and in defence +, and I need to stay in this configuration.
Can somebody to tell me want can I do in this situation?

PS. I have another programs wich don’t run, like firefox.

Thanks in advance

Do you happen to run a 64bit version of Windows ?

No, I’am running Windows XP SP3 32bit version

Okay, can you please expand in the “not running” is that “firefox won’t start/show” or are you unable to browse with firefox ?

The difference is the first is likely to be caused by Defense+ the second by the Firewall.
You can test with setting D+ or Firewall to disabled and then test to see how far it goes…

I would set Firefox on Firewall to “Outgoing only”. For D+ I’d use Custom.
To make sure you did not block anything for Firefox you could remove the firefox entry from the Computer policy and then restart the computer, now use Firefox again and if it alerts be sure not to use “Block” if not needed…