some help to config Comodo FW for Adobe Dreamweaver pls

im having some problems configuring the FW to allow me to connect to my FTP host with Dreamweaver, im getting blocked but i just cant figure out how i allow it to connect.

in my “Firewall Events”

Windows Operating System Blocked TCP xx.xx.xx.xx 20 xx.xx.xx.xx 5003 date

i cant find whats blocking it, iv also tried to make a network policy for “System” that “allows all TCP/UDP” but it still blocks so as you can tell i really dont understand darn FW’s, never have, always caused me more problems than i can stand but i really want to try to get to grips with them so any help on this would be gratefully received.

thx all.

p.s did try to attach a pic but couldn’t c how to attach it into the text. not my day :frowning:

[attachment deleted by admin]

Welcome to the forum JackDinn :slight_smile:
Please check your Firewall/Network/Global rules as these are checked first for incoming and this is a incoming block.
Dennis

hi, thx for the response,

i did have a good look at the Global Rules but couldn’t find anything that would look like its a block on TCP, all the block rules are for ICMP.

[attachment deleted by admin]

Please try this topic or this one.
It appears from the first topic you might have to create a incoming rule in global rules which is odd as you have none blocking.
Dennis

I had the same problem and had to do this: * Look at the Firewall Events for Dreamweaver. Write down the Source IP and Port (possibly 20). * Firewall, Advanced, Network Security Policy, Global Rules - Allow TCP In - Source: [Source IP noted above] - Destination: Any - Source port: 20 - Destination: Any

well had already tried adding a FULL Allow here so i knew it wouldn’t work but i did as suggested but no go.

It sounds like a Defence+ issue Try Changing the Defence+ security Level to training mode and then run all the programs you wish After that change back to clean pc or safe mode Before changing to Training mode, make sure there are no existing rules for the programs you are training CIS for.

Defence+/Advanced/Computer Security Policy, locate and select the program and remove it. Click Apply to complete the process.

Firewall/Advanced/Network Security Policy. Same procedure.

and this , hmm, well im not sure if its anything to do with Defence+ as if i turn off the FW it works fine (connects to my FTP host no prob) even with the Defence+ left on.
but i did what was suggested anyhow but again no fun :frowning:

thx for the help though, its all appreciated. just hope we can get the answer as it seems iv stumbled onto a problem that is not just me being ignorant as it usually is :stuck_out_tongue: the posts you pointed me towards show this exact problem with others and it dont seem to have a solution yet, except from turning of the FW each time but that’s NOT the answer.

cheers.

Can you show me the Application Rule for Dreamweaver? Try making it Trusted Application.

mine works fine
attached are my all global rules, my Dreamweaver application rule my DW D+ rule.

What version of dreamweaver?

can you connect with an ftp client.

[attachment deleted by admin]

can you connect with an ftp client.

yep i can log in fine with filezila ! and DreamWeaver is ver 9 but that shouldn’t affect the FW

i hope these pics bellow are what your wanting to c , not 100% sure

also how do i make an app trusted ? i can see

“my Trusted software vendors” &
“my own Safe files” or
“use custom policy - copy from - predefined security policy - Trusted Application”

not sure which is to make a trusted app.

[attachment deleted by admin]

You can make it trusted under Network Security Policy → Application rules.

Let us know if that helps or not.

o i duno , iv tried it as a trusted app and also tried as a FTP Client but still just wont go through,

i’ll just disable the FW when im using dreamweaver, or remove the FW altogether.

never found a FW that didnt cause some kind of problem or other :frowning:

thx for the help offered from all.

[attachment deleted by admin]

Just one last suggestion from me could you please try moving the rule for dreamweaver to the top of the list.
Dennis

yea have put it right at the top but still no go.

what i dont understand is why when i can see the log of it being blocked i cant then track down what exactly is doing the blocking ? shouldn’t it say somewhere on the log what policy or defined rule is causing each logged activity or maybe a context menu with an option to go-to the rule/policy that caused each log entry.

It should but in your case it does not, why I do not know.

Screenshot below my block top outgoing shows application, CIS block bottom one is incoming so if I wanted to allow I would create a Global rule.
Dennis

[attachment deleted by admin]