Some entries in "My own Safe files" constantly disappear

How it happens on this system:
Entries (entire folders + subfolders e.g. whole %programfiles%) are added to “My own Safe files” (MSF) db. The list becomes rather/very long. After some (one?) reboots list of entries in MSF becomes severely cut. Reason unknown.

System:
Windows XP Home SP3 x86, latest updates, admin account.
CIS v4.0.13…742 – D+ in Safe mode, Fw in Safe mode, SB disabled, AV not installed, proactive config.

Similar reports?
https://forums.comodo.com/empty-t37213.0.html
https://forums.comodo.com/empty-t53120.0.html

Problem: My Safe files loses many entries on reboot (without warning) when there are a large number of safe files

Checking this against a larger number of files than previously reveals that is still present in 4.1, contrary to my previous belief that is had possibly been resolved.

Steps to replicate:

  • Install full version of Autocad 11 trial (not LT version) with all optional packages from www.autodesk.com
  • Add the directory c:\program files\autodesk to My Safe Files, including subdirectories
  • Count safe files by estimating number per page and counting number of pages of safe files. You should get about 1170
  • Reboot the computer and re-do count of safe files. I get approximately 600 files when I do this
  • Note that no warning that files are being discarded is received

Other information

  • Your Operating System (32 or 64 bit) and Service Pack revision: XP SP3 32 Bit (Pentium 4 CPU 3Ghz, 4Gb RAM) Admin account.
  • CIS version: Please see title
  • Other Security and Utility Software Installed: See appended config report for details. Usually: Comodo - CIS, CVE, CIV, CLP, CSE, CAS, IVault; Other- Filezilla, Wallwatcher, Sony Ericsson PC software, Actual Window Manager, Routerstats, Revo, Process Explorer, Google Desktop, Process Tamer, Process Explorer, Idrive, Clipmate, Stuffit
  • Step by step description to reproduce the issue: See above
  • How you tried to resolve the problem: N/A
  • Upload Memory Dumps on crash if you encounter any: N/A
  • Attach screenshots to your posts to clarify the issue further: N/A
  • Virus database version: Please see config file
  • Any other information you think that might be useful. CIS settings:See appended config report for details (to follow).

Best wishes

Mouse