[SOLVED] Why does CIS prevent me from downloading µTorrent?


I’m using CIS 7.0.317799.4142 on Windows7.

I was trying to download the µTorrent client, but Chrome says:

The page is blocked by COMODO Internet Security Premium. Contact your system administrator.

Does someone know why, and what I should do?

Thank you.

After closing the CIS application in the icon bar, I tried stopping the two started Comodo services by running c:\Windows\System32\compmgmt.msc as Administrator, but the pop-up menu is all disabled, so I can’t choose “Stop”.

Why are the menu items grayed out when running Computer Management as Admin?

C:\Windows\system32>sc stop “cmdAgent”
[SC] ControlService FAILED 1052:

The requested control is not valid for this service.


You probably are using Comodo Secure DNS. Try disabling Secure DNS as described in: http://download-new.utorrent.com/endpoint/utorrent/os/windows/track/stable/

After you did this run the command prompt. At the command prompt execute: ipconfig /flushdns . When needed restart your browser; browsers may also use their own local DNS cache.

Try temporarily disabling the website filter here:

The URL doesn’t contain any information about the issue.

In the “Internet Protocol Version 4 (TCP/IPv4) Properties” dialog, both “Obtain an IP address automatically” and " Obtain DNS server address automatically" are selected, so it doesn’t look like the computer is using Comodo’s Secure DNS (which makes sense, since I unselected that option when installing CIS).

For the “Blocked Sites” item, I moved the slider to “black X”. That did it. Thanks.