Solved - Unable to launch IE 8 with Defence+ Enabled

Hi everyone,

I am unable to launch Internet explorer 8 while the Defence Plus is enabled in any mode.
When I try to launch it, it just flashes very quickly and disappears. Defence+ event shows it was trying to install a hook (MSCTF.DLL from system32) but does not say whether its been blocked. This is happening recently and I had no issues with it before. I have checked the IE is added to my safe file list. It also runs in the process when I check the Task manager. Manually killing it and trying to launch again has the same results. Works fine when Defence Plus is disabled.
I am running Comodo IS Premium.

Please help someone. :-[

One small question. Have you removed ‘All Applications’ rule from Defense+ Policy?

CIS-Defense±Advanced-Computer Security Policy

This rule gives access of Windows Event Hooks to

msctf.dll, shell32.dll, browseui.dll, ieframe.dll

Probably, if you have removed it and if separate rule does not exist in Computer Security Policy, Defense+ must be blocking it. The log shown in Defnse+ is actually a ‘block’ rule by Defense+.

You may keep Defense+ to ‘training mode’ (Right Click CIS Tray Icon - Defense±Training mode) and rune IE8 once and then change it back to safe mode. That should normally solve the problem. Unless a separate block rule is given for msctf.dll under

CIS-Defense±Advanced-Computer Security Policy-IE-Access rights-Windows event hooks

Hope this helps

Thank you for your reply :slight_smile:
I’ll check the rules today and post what I have.

As for setting the Defence+ to training mode and trying, already did that with the same results :frowning:

Thanks Layman. That solved it.
I allowed the windows event hook in IE custom policy and it worked ;D

Thank you :slight_smile:

Very happy to know that.