[Solved] Saved configuration doesn't work


O.S. : WinXP Home32SP3 up to date.

Comodo Firewall : v5.8.213334.2131
Highest Alert level
Custom policy mode

I’m using a saved configuration
but comodo doesn’t take its rules into account.
Note : It contains sets of firewall rules I created and sorted.

example :
I have primary and secondary DNS requests set for an application ;
Nevertheless Comodo pops up asking
if I want to allow DNS request for this application.
I check [remember] and allow the request.
It keeps poping up displaying the same
primary and secondary DNS requests until
I finnaly uncheck [remember] and allow both requests.

I’ve tried uninstalling and re-installing Comodo Firewall
but the issue remains.

Did you activate the configuration after you imported it? If you did, can you post a screen shot of the Applications rules and the firewall logs.

Yes, the configuration is activated.

I’ll take cfpupdat.exe as an example.

Cfpupdat.exe with no rules.


Allow DNS requests 6 times while [Remember my answer] is checked.
Allow Secondary DNS request while [Remember my answer] is unchecked.
Allow HTTP request 3 times while [Remember my answer] is checked.
Allow HTTP request while [Remember my answer] is unchecked.
Allow Primary & Secondary DNS request while [Remember my answer] is unchecked.


Blue background means that [Remember my answer] was checked while answering Firewall popup

In the end, the update fails (for it to work, I have to answer the pop-ups with [remember] unchecked).

Cfpupdat.exe firewall policies.


Just out of curiosity, what happens if you use a clean default profile with Custom policy and alerts on very high, as opposed to importing your own?

I did what you proposed.

I also added an Ask IP In/Out From Any to Any for the “All Applications” File Group.

That caused the issue to appear.
I removed the rule…
…Issue disappeared

How can you have Comodo FireWall alert the user
for any application trying to access the internet
unless you set such a rule ?

Is this supposed to be the expected behaviour ?

Can you try to reproduce the issue ?

You should only need to place the firewall in Custom Policy mode and increase the Alert Frequency to high or very high depending on how much detail you require. With these settings any application for which no rule exists will prompt. Likewise, if an application has a rule but something changes, such as the path, version, protocol, destination IP address etc, you will receive a prompt. It should not be alerting you for the same rule if nothing has changed.

Thank you for your help :slight_smile: