[solved] Problems on 2 PC's since Comodo Firewall 10 installed automatically

To clarify what I did in order to install Comodo 10, I went to the Control Panel, Security screen where you can click a link at the left side of page (Win7) that says “turn on or off Windows FW” and turned it off per screen instructions.

I then did this: Hit Start button, typed in Windows Defender & hit enter. Selected Windows Defender and it opened the GUI. Went to Tools button and selected Options. Clicked Administrator link at left of screen. Unticked WinDefender’s “Use This Program” to right. Turned off Realtime Protection. Saved and Exited. I also went to Win 7 Administrative Tools, Services, and stopped the Windows Defender Service.

I was referring to Comodo Firewall. Sorry for the confusion.

BINGO! Man, sometimes you can’t win for losing. I may have found the problem, but it will not be pretty to clean things up. Apparently when I turned off the Win7 Firewall via Windows Ctrl Panel, chose FW and ticked to turn it off, THAT apparently only turns it of FOR THAT SESSION!!! Microsoft really need to work on that. It should turn the service off, too, or make it apparent another step will be needed to accomplish a total shutdown of the FW. Unless you go out to Services and DISABLE the FW there, and it was set up in “started, Automatic” mode, it will turn itself back ON at the next reboot!!! I know, because I just went to services ont hat PC and the ■■■■ Win7 FW IS ON!!! Grrrrrrr. So I have now permanently DISABLED the Win FW Service and Stopped it (I hope). Microsoft should improve/fine tune this user capability to avoid any misunderstandings as to exactly what “TURN OFF” means. Grrr. Don’t get me started on Microsoft.

I rebooted my husband’s PC just now and checked services again and now the Win7 FW it is truly disabled. Thank God, finally! But what IS perfectly and painfully clear to me now is that the Win7 FW was running when I rebooted my machine to install Comodo10 on-line. It likely prevented a clean install. So the only course of action left for me would be to now uninstall Comodo 10 on his PC (again) as cleanly as one CAN uninstall Comodo, run the special remnant removal tool in Safe Mode, reboot (checking those 2 services one last time before proceeding) and if both services are disabled, I can then reinstall Comodo 10 (hopefully cleanly). Perhaps that will resolve my on-line navigational issues.

Yup, Win7 does have quirks and that is one of them. Glad you found it.

I hope I’ve found it, Swatbat. But it ain’t over until the fat lady sings (not a reference to myself, LOL). Guess I know how I’ll be spending my day. Thanks again for following my thread of woe and your advice, Swatbat.

Windows Firewall does not interfere with installation. No need to re-install.

Well whatever the cause, my first install on a new OS PC was either corrupted, or a custom Firefox application rule was in the way. I just know that uninstalling Comodo, running removal tool in safe mode, rebooting into normal mode, making sure this time WinFW and WinDefender Services still were both DISABLED in Windows Services listing and then reinstalling Comodo has resolved all my navigating issues on the internet for both defined user profiles on my husband’s PC. So I think it DID indeed have something to do with impeding of a clean install first go-round. That’s all I did differently this time. But I’m very relieved the issue appears to be resolved. Windstorm. Thanks for your help throughout my crisis.

No problem. Now, we can enjoy a nice low-carb snack. Glad it’s solved.

Well, we went out to dinner to celebrate both PC’s being back to some resemblance of normalcy and able to navigate the internet once again. But our celebration was premature. Husband’s PC is working OK but mine is not. This afternoon Comodo said there was an update and I hesitated for awhile, but thought maybe they got the UNDELETABLE DESKTOP ICON ISSUE and other 10.0.1.6209 problems resolved, so I accepted the update. BIG MISTAKE!!! When we returned from our celebratory dinner, I booted up my PC and when it got to Windows user log-on screen and I keyed in my password, I got the exact same message from my operating system we both got 6 days ago after the 4/16 update when this fiasco all began: “Windows was unable to connect to the System Event Notification Area. Contact your administrator.” After 3 attempts, I can’t boot up my into normal mode, but can boot into Safe Mode. Unfortunately, I can’t uninstall Comodo in Safe Mode!!! Folks, I’ve about had it. If you can’t get updates to take place without such bugs, I don’t want to run Comodo on ANY machines again. But I need to figure out a way to uninstall it from Add/Remove programs and can’t get there! Am I going to have to deep-six and go back to out-of-box state and reinstall all Win Updates and all software again on MY computer as well!!! This is simply unacceptable folks. I’d rather go through the arduous, painful process of learning from scratch how to use the Windows Firewall or some other FW/Security suite than to keep having to deal with this mess after every update.

I’ve just now gone into my husband’s PC which apparently did NOT get an update offer this afternoon and is still working OK and totally disabled Comodo updates on the General Setting, Updates GUI. I can’t afford to let today’s update get downloaded to h is and ■■■■■ up his PC, too. I need to go out an find a Firewall that WORKS and download it! Grrrrrrrrrrrrrrrrrrrrrrrrrr!

Well, now I’m more confused than ever. I walked away long enough to go to the hubs PC (maybe 5 minutes) and typed my last reply and by the time I got back to my PC, Windows must have found the System Event Notification Area because one more attempt to log onto my regular user account and the admin accounts worked without rendering the same Windows error message. I could even still get back onto the internet as am typing this reply at my own PC. What gives?

Do you think something about Comodo starting automatically at boot up is butting heads with Windows boot up process? I really don’t let much run at startUp and this screen shot shows all that is running at Start Up on this machine:


http://i217.photobucket.com/albums/cc278/buttonbutt/Miscellaneous/Capture_6.png

FWIW, my PC HAS been booting much slower since the upgrade to Comodo 10.0.1 6209, so perhaps it is a classic case of Comodo 10 and Windows7 butting heads at boot up. Any suggestions to locate the problem and correct the conflict would be appreciated. Could Comodo Security Essentials, the new component, be the culprit here?

Windows Installer does not run in Safe Mode. Use this tool to enable it in Safe Mode:

After that, try to uninstall it from Control Panel.

Slowdown could be caused by Internet Security Essentials. Not very sure.

Thank you. That will be a useful tool to keep around for many safe mode uninstall uses. Didn’t know such a thing existed.

I’m finding this morning if I boot up my PC and simply wait until the CPU activity light stops wildly flashing to log on, it lets me log on OK. But if I try to log on as soon as Windows offers my log-on icons (light still wildly flashing), that is when I’ll get the error message about Windows can’t get to Event Notification Area and locks up, requiring a forced button shutdown.

So clearly it would APPEAR to be a boot up situation where everything is competing to boot up, turn on and probably not a bad install? So I have two questions for you: Should I uninstall in normal or safe mode for best clean out results? Should I uninstall the entire Comodo 10 package or just the Security Essentials Component, as a test, to see if that component alone is the cause of my problems here?

Yes, try to uninstall it. If issue persists, try to disable HIPS, Sandbox from main user interface.
If possible, you should perform normal uninstallation.

For now, since you didn’t say, I decided to go into Safe Mode and uninstall the Comodo Security Essentials component ONLY. Rebooted 4 times into normal mode to see how things are booting up. Boot-up time is now normal for this PC (5-6 seconds) and I was able to log-in all 4 times IMMEDIATELY when Windows offered log-in icons (no 15 second wait needed to avoid the dreaded error screen) and my desktop opens right up. My Internet is fine, I can navigate to any web pages. Another thing that has improved is the lag time from hitting CAPS LOCK and the Win7 audible beep I’ve set for that key, has gone, whereas before this step, there was about a 3-4 second delay. So it would appear that something in Comodo Security Essentials is either hogging resources or conflicting with some pretty important Windows functions. I’m glad I’ve uninstalled that component now and will not uninstall the full Comodo FW package just yet. I hope my current problems do not persists.

I hope future updates don’t go and reinstall the CSE component back on my system else this nightmare is going to repeat itself again. BTW, I’m one of those that did not see the special tab for opting out of things on your installer’s UI. That needs to be right on the first tab so people can SEE it.

Just to let you know that after many cold boots and soft boot restarts now, I’m having absolutely NO problems with my PC, at boot up or otherwise. Clearly the Security Essentials part of the update appears to be what was not co-habitating nicely with Win7 Home This really is a very basic, uncluttered machine. Other than my security software, Firmin to minimize FX memory usage is all that’s on here and it has never conflicted with the Firewall before. I made NO other changes other than uninstall the Security Essentials via add remove (since I had already reinstalled the FW. My Firewall rules are out of the box other than 5-6 additions recommended by mods here in the past. Perhaps you can steer your troubleshooting programmers in the direction of Security Essentials to resolve many of the issues people are experiencing.

I think you can safely make this thread [Solved].