[solved] Problems on 2 PC's since Comodo Firewall 10 installed automatically

My husband and I have been running Comodo Firewall for years. The automatic update to version 10 that occurred on my PC on 4/6/17 has ■■■■■■■ both our systems. We both keep getting a Win7 (64 bit) error message: “Windows unable to connect to System Event Notification Service. Contact System Administrator” and our screens just go black and freeze as soon as we click OK in that pop-up box. BTW, on both PC’s, our Windows System Event Notification Service is on, Started and set to run Automatically. After several hard boots, I just now finally got my PC to at least boot up successfully long enough to do a system restore back 4 days, which was successful. Will attempt to go do that on my husband’s PC, as he knows zero about PC’s. He barely knows how to copy/paste! :slight_smile:

The OLD version Comodo interface icon is now happily back on my screen since my successful System Restore and all appears to be OK again. But I don’t want Comodo to try and update automatically to version 10 again until you folks get this problem fixed. From the posts I’m seeing below today on this forum, there appears to be quite a problem with this new version 10. I also went to Broadband DSL forums to see if anyone was screaming about a Windows Update issue for the recent updates and there does not appear to have been a problem for anyone. I immediately began to suspect the Comodo update was at the root of our problem. HELP!

Just opened up my older version via tray icon (assume the version just before 10, sorry I don’t recall the version number on my old version before this update) and it isn’t responsive to clicking the “task flip” feature, so perhaps all is NOT ok. Can’t click the Firewall button on the left either. Just sits there when clicked. Comodo says my system is “secure state”, and I certainly hope so. But when I click the tray icon, the interface for updates says current product version is! So perhaps my System Restore did NOT go fully back to the old version!. Grrrr.

Were you using HIPS? By the way, some users mentioned trusted vendors list was lost after update. Not sure if it’s relevant in your case.

Unless built into the old Comodo version as Defense+, I haven’t used a separate Hosts file (other than Win7 built in Hosts file) in some time, if that’s what you mean. Defense+ and Sandbox WERE enabled during the update as they always are turned on, but they have never caused updating problems before. Almost none of the user interface clickable features, in particular the TASKS button, are working at present, so I can’t see Trusted Vendors or any Comodo detail information. I’m sure my installation is corrupted royally, with bits of both versions still on the system. Why else with my System Restore back 4 days would it say I currently have version when all the while the old tray icon and widget are displaying?

I can get to the interface screen to disable my HIPS (D+), and Sandbox now. Do you think with those disabled, if I tried to run the internal updater again it would resolve my issues? Or will that just make things worse and only a clean install will resolve this? I downloaded the stand alone CPFW installer from Comodo.com just now, could uninstall Comodo entirely, and reinstall, but that doesn’t make me a very happy camper. If I have to go that route, and I clearly can’t get to the config export screen up in my user interface, can I just “copy” the .cfgx files that live in my current Comodo folder to my desktop and import them to my clean install of CFW? I sure don’t want to have to build my FW rules from scratch on two machines.

Also, are you folks currently recommending uninstalling via Control Panel, Remove Programs (on 64 bit machines)? Or should I use the built in Comodo Add/Remove Components feature in the start menu? And are you still recommending using that special non-Comodo group batch file/removal tool in addition, as you once recommended to get rid of remnants? If so, I have just downloaded a copy of the old batch file onto my desktop.

Try jumping to Advanced Settings by launching :
“C:\Program Files\COMODO\COMODO Internet Security\cis.exe” --configUI
ALT+C, ALT+E keys

As for uninstalation method,
try uninstalling it via normal way, use removal tool, restart, use removal tool (again).


Nope. Actual config is stored in registry.

Should be OK.

Thank you for your help, Windstorm. OK, so you think a complete uninstall and reinstall “might” fix the problem. We’ll see if that is the case.

If I might make a suggestion for programming changes. Seems to me having HIPS on has caused major updating issues more than once in recent years. If this is such a persistent problem, how difficult would it be to add some up-front programming lines to the updater/installer executable that has it go out and check to see if HIPS is turned on? Other software I have used is able to do a “condition search” like this and warn before proceeding with further action. Even better, then when HIPS is “enabled” on the system, have the internal updater terminate the update process altogether, with a pop-up screen something like “HIPS enabled, unable to proceed with update”. Is that really all that difficult to do when other companies seem to be able to pop up such warning boxes? We all know HIPS must be turned off to do installs of programs, but your updater does not give us an opportunity to stop the process and marches right on and updates, screwing people’s machines up and causing a real nuisance that after multiple events, leaves a very bad taste in one’s mouth for what otherwise, has been a very good security software for me.

Unable to directly invoke Advanced Settings via your instructions. When the UI pops up, Windows just beeps at me when I hit the Alt+C and Alt+E. So I must uninstall, reinstall and reconfigure rules from scratch it would appear. Not a happy camper here.

My uninstall and clean reinstall of CPFW 10 is running OK now. GUI is now working properly, too. It apparently pre-set a lot of the rules I used to have to input manually. I only had to add in manually 2-3 rules not there automatically. I ditched Geek Buddy and Comodo Dragon via Add/Remove Programs.
Only problem is the unwanted Desktop Icon WILL NOT delete via usual manner. I keep deleting and it keeps reappearing. I’m sure you’ll get htat bug fixed soon.

I do hope you’ll pass on my suggestion to programming so this terrible inconvenience after major program updates doesn’t happen to so many people. It’s really not nice to deal with this again and again. This makes I think my third time to have to go through all this rig-a-ma-roll.

Really sorry for your troubles. Predefined rules already exist (which I think you’re suggesting) but you ran into some other issues they’re aware of, I’m guessing. They’re trying to fix these as soon as possible. Hope that I’m not misunderstanding.

Well, I spoke too soon. The uninstall/reinstall may have gone fine on my 64 bit machine, but it’s a disaster on my husband’s 32bit machine. Every time I uninstall the Comodo Firewall, he loses his internet connection totally (needed to download the new version). System restore back a week re-establishes his connection to internet but his Comodo is not loading at all anymore (says Windows can’t rind CPF.exe, which is really not in the Comodo directory anymore). So at this juncture, after two retries at uninstall/re-9install, no connection to do so. As another user mentioned, you really need a stand alone installer for such botched install disasters. So my only recourse on this machine will be to revert it back to out-of-box condition, reinstall all software, reconfigure all software and pray that Comodo will install OK with no corrupted install getting in the way. I’m really not happy about having to do all this. I’ve spent the entire day on this debacle.

Try removing the Comodo drive from your Network Adapter . . . .

And Comodo wants to do away with the offline installers in favor of web installers… LOL at this bogus thought when Comodo always botches peoples internet as I’m reading.

Ploget, I did what you suggested but it still does the same thing. The minute I go out to Safe Mode and run all the removal tools and go back into normal mode to remove via Add/Remove Programs, he has lost his connection to the internet. I’m tired of System Restoring and fooling with all this and will just restore his machine to out-of-box state and reinstall all SW from scratch. At this point it would be easier. But if CFW 10 doesn’t install properly for me on a blank slate, I’m ditching Comodo for good on this PC. Just not worth fiddling with this any longer.

[at]buttoni - same problems here on all flavors of Windows and on all flavors of hardware. The only thing I found is that Comodo somehow corrupts the drivers (Comodo’s issue and no one elses) so what I did for more than 37 systems is uninstall the Ethernet and/or wireless drivers until you have just the one. If you uninstall and hove no drivers left, then use your other system to download them, put on a thumb and copy them over. Then install the Ethernet/wireless drivers and you should get the Internet back

NOTE: Another point I found is that during the uninstall the firewall driver is not removed from the network devices. Some of the mess I am cleaning up I came across this. Once I uninstalled the Comodo program, the Internet was working perfectly again. Network Settings > Change adapter settings > right click on hardware and select “Properties” and there you will see the firewall driver. I’ve worked on 11 systems, uninstalling Comodo and then finding out that these are still installed even after running the removal tool. Try there too

This update is a huge headache here and justifiable why so many are upset.

Well, I can get to the internet on his PC, connects for both defined users now. But odd thing is that I can only get to AT&T home page, Facebook and FoxNews website. Can’t get to the Activation site for my MS Office re-install today (or any other sties I’ve tried to go to via Google search results links. The fact that the broadband connection through the Uverse router isn’t being blocked in any way by Comodo makes it sound almost like a DNS address problem, but I’ve set Comodo FW and HIPS to ALLOW traffic out to DNS Service for Firefox.exe. I’ve rebooted/reset my Uverse router. The mere fact that Windows has been downloading updates for 2 days straight with success I know the router Internet connection is viable. Something just won’t let me navigate to anywhere I want to go once I get to the Internet!

The default Comodo installation has always worked for me until I could enter a few additional generic rules mods here have provided in the past that have always worked well for my Comodo setup.

I frankly don’t think I’m knowledgeable enough to go uninstalling (or reinstalling) ethernet drivers willy-nilly. I barely know what drivers ARE, quite honestly. Moreover, I am not comfortable doing that when I have what appears to be a working install, a GUI that is working and a viable Internet connection. Clearly you’re an IT manager; I’m a 68 yr old lady who really doesn’t understand hardware and drivers (and don’t want to, to be very honest). This is waaaaay over my expertise level. I may be forced to consider his PC a lost cause for the time being, and keep his PC off-line for his playing Windows Solitaire and Majong (sharing mine for when he want to go on-line. Mine is having no connectivity/navigating issues other than the Comodo desktop icon that will not delete. We have a PC guru friend that visits occasionally and perhaps he can help us with this. But I do thank you for your help. Best of luck with your 11 units out there. :slight_smile:

No problem. Some of my clients are around your age so I completely understand. Good luck as all of us here are as well

Hi again buttoni,

Try launching : cmd
(eg Windows+R keys >> type: cmd)

Type: netsh winsock reset
Restart system
Check issue (again)

Hi, Windstorm. I did the “netsh winsock reset” and rebooted, but the same problem persists. I get to the internet, att.com home page fully functional, can go to FB, FoxNews, Wikipedia via Yahoo search engine or Google search engine, but not to Atkins.com, any of my low-carb favorite blogs, not to my own recipe blog, Web MD, ARIN Whois? or to the Comodo help forums. It’s odd how a few sites, however, can indeed be found, isn’t it?

To paint a clearer picture, I did an F11 restore of his PC to out-of-box manuf. ship state with a clean OS. Reinstalled Comodo FIRST, on a clean Windows install. Windows FW was turned off by me, and MS Defender realtime protection turned off (service turned off, too). So there simply couldn’t have been any conflicting security SW issues that caused a corrupted install to my way of thinking. That’s why I’m wondering if my issue cause might be one of my Comodo FW rules (or lack of a needed rule) rather than my CPF install being bad. But I’ve re-check my FW Global/App rules, HIPS rules again and again on his PC and they just don’t look wrong. The order of the rules seems to be correct. Nothing outwardly seems lacking in the rules setup. When I compare his config rules to MY computer’s Comodo rules, they look good and proper to me.

Did you try to disable FW from main user interface? Does it still not work? Just to double-check.