[SOLVED] Issue with Firewall & Assassin's Creed Director's Cut

Hi Everyone,

After a lot of troubleshooting and me starting to get more and more drastic, I finally figured out what the issue is, but I cannot fix.

When I play Assassin’s Creed Director’s Cut (aka AC1) the game crashes to desktop after a few seconds. How did I come to the conclusion that it’s COMODO Firewall is the issue? Well, one of my drastic issue was to uninstall COMODO Firewall and try playing without it installed and guess what I was able to play?

Can anyone help me in figuring out how to get AC1 and Comodo to play nicely together?

I found half a solution (below) but I had to block all exe’s in the AC1 ffolder in the firewall application rules too.

  1. Open the Comodo settings menu.
  2. Select HIPS > HIPS Rules
  3. Add a rule for the AC .exe
    a. Select “Use a Custom Ruleset”
    b. Scroll down to “DNS Client Service” and under the “Action” column click on “Ask” and
    change it to “Block”.
    c. Click “OK” to add the rule.
  4. Click on HIPS > HIPS Settings
  5. Click on “Enable HIPS”.
  • I left the default monitoring to “Safe Mode”. I didn’t want to have to add a rule for everything
    that came through as I never had a problem before.
  • I also checked the “Do not show popup alerts” and left it “Allow Requests”. Everything else
    I left alone.
  1. Click “OK” to apply the settings.