SOLVED=>I can't run 16 bits DOS application after I upgraded COMODO firewall

I had not upgraded COMODO firewall for a long time because I need to run foxprox.exe wich is a 16 bit application.
Now I upgraded my hard drive and made a clean install of Win XP SP3 and COMODO CIS last edition downloaded from internet
I got this message : “Acces is denied” when I tried to run foxprox.exe
I renamed guard32.dll and rebooted.I got the same message

SOLUTION
I made a clean install ( XP SP3 ) and I installed again CIS 4
It works now I can run my old application in 16 bits with no problems
The sandbox and pro defense are disabled.I have running only the firewall
Thank you for help

Hi gabi128, welcome to the forums.

I’m not running CIS 4 myself yet, but based on what you’ve said, I suspect that this is something to do CIS 4’s sandbox (a new feature of CIS 4). Since the sandbox is, effectively, a virtual environment (either 32bit or 64bit), I can understand why a 16bit application might be having trouble with this. You probably need to make sure Foxprox doesn’t run in the sandbox (something that I believe it probably does by default).

The driver guard32.dll is part of CIS’s Anti-Virus. So, it probably doesn’t help to disable this.

I hope that helps and I’m sorry that I cannot give you precise instructions on CIS’s sandbox (hopefully another forum member will assist you in that regard if you need it).

Guard32.dll is part of D+ if I recall correctly.