(solved) Firewall unable to update itself - error 0x80072eff

I’ve been using the firewall since I got this laptop back in 2011. Yesterday the firewall was updating itself but the installation got stuck and, after more than half an hour I decided to cancel it.
Then followed hours lost because the firewall decided to block any application (I could access only to folders but not launch anything, Windows Restore included unless launching it in Safe Mode) and I wasn’t even unable to uninstall. Anyway, after much working around and an heavy use of revo unistaller I managed.
I re-installed but the firewall suddenly couldn’t update, giving me “error 0x80072eff (the network has been reset)”, although it still registered the last update as “six month ago”.
Today I decided to uninstall again with Revo and then followed by a couple of cleanings with CCleaner to then launch a clean install again. This time the “updated six month ago” has vanished but the firewall still gives me the error 0x80072eff when I try to update.

I’ve seen I’m not the first to get this error but no reply was given to the other users who posted with this error in the past.
The only solution offered some years ago, for a similar error, was to go edit the registry but I’m not really up to, since it meant changing a key about windows connections. Another suggested to try download a 100mb file from the site and I was able to do it, so I have no issue with the server per se.

If I don’t get a solution in the next days I will sadly have to look for another firewall. :frowning:

[Not sure if it helps, but the version I uninstalled yesterday was named, in the Windows Installer window, as “Comodo Internet Security”, and not as COMODO firewall like the one I currently have]

Are you kidding me? The issue was given by the server link in the update?

Out of an inspiration, I tried to remove the secure https to replace it with a http, and the update started and went smoothly.

So, yes, as of now the solution was found, although I’m not sure if it’s safe or what. :slight_smile:

Also, it seems that adding the specific (current) IP of the server [ ] solves the error as well. IP suggested by another user (they suggested to add the server to the Windows Hosts file).
In any case, it’s important you tick off the “standard” server (https://download.comodo.com") by making it go from green to grey [I use the classic theme, but it should be same even with the other graphics]