[SOLVED] Firewall blocking when I power up a Virtual Machine.

Every time I start a Virtual Machine in VMWare Workstation, I get Firewall BLOCKING events & logs in CIS Firewall on the host.

Please, what does it do, and how can I allow this for the 192.168.216.* IP-range ?

[attachment deleted by admin]

ICMP Type 8 Code 0 is an echo request (also known as ping). Blocking the echo request is part of the default settings of the firewall.

Are you experiencing problems connecting or are you wondering about the alert?

Hi Eric,

Thanks for explaining, no I have no prloblems connecting, I was just wondering about the alert and because I didn’t see any proper way to allow these connections from the same computer.

Is there any way to not block these kind of requests between the host and guest(s) ?

You could add a Global Rule to allow for accepting echo request.

The two IP addresses from what machines are they? Is one the host OS and the other one the OS in the VM?

Yep, they’re from the same computer.

Host = XP SP3
Guests = XP SP3 & Win7 Home

Host =

To allow a ping request go to Firewall → Advanced → Network Security Policy → Global Rules → Add → now fill in the following
Action: Allow
Protocol: ICMP
Direction: In
Description: Allow ping

Source Address: Any
Destination Address: Any
ICMP details: ICMP Echo request
Now Ok and Apply your way back to the main screen.

You can fine tune Source and Destination Addresses to your likings.

Sorry for the late reply Eric,
it worked fine allowing ping to destination range to