[Solved] Delphi XE bds.exe application failed to initialize properly 0xc0000005

That’s what i get after installing CFW 5.3, the only way Delphi will work is if I disable Defense+ permanantly and restart, enabling it again (even if I change the policy Paranoid, Safe PC Mode or Disabled) I get the message again, I guess it’s bcoz of some anti-debugging protection anyway, how can I solve this? Thanks.

You’re running quite old version of Comodo firewall. I suggest you to uninstall it with Revo Uninstaller and after restart install the latest version (5.3). When you do that, report back if the problem still persists.

Sorry, my bad i meant 5.3

Could you post a screenshot of Defense+ Events?

There is no Defense+ event, all I’ve got is the error message when I lanuch the app (bds.exe) (bds.exe application failed to initialize properly 0xc0000005)

Do you have anything listed in the Defense+ → Computer Security Policy → Blocked Files?

No, it’s empty.

Follow these steps and report back if you managed to solve it.

Sorry for the delay, I was busy, anyway it worked thanks alot. I added bds.exe to the exclusion list under Detect shellcode injections (Execution Control Settings) and now it works like a charm. Thanks again :wink: