[SOLVED] Comodo Firewall blocks Minecraft server

So my problem is that Comodo’s firewall is blocking all outcoming connections to my Minecraft server, even though I have set an application rule to allow every connections coming to javaw.jar, which Minecraft is using. I have also set a global rule to allow the port Minecraft is using, which is 25565. I also added the 25565 port to the firewall port sets config, which didn’t help. I have also reinstalled the firewall, which didn’t help either.

I can connect to my Minecraft server using localhost on my own computer, but when I use my external IP address or others try it, it won’t connect.

I have to disable the firewall and just then I and others can connect to the server with my external IP address. I just don’t want to keep Comodo disabled since I’m planning on continuing to run my server almost 24/7. This is not the first time I’m running this server, I have been running it for me and my friends for years now, but we haven’t been playing much lately so I haven’t been keeping my server up lately.

Now I’d want to play again, but even if I haven’t changed any settings, Comodo won’t let me connect. Is it because of newer Java or server version or newer Comodo version I’m using?

I have been using Comodo for years now, and would like to continue using it, but I can’t use Comodo if I want to play Minecraft with my friends, so does anyone have any clue what could be wrong?

Thank you.

Did you port foward in your router? Try doing so and allowing data on port 25565 to your computer.

Make sure your set to “Alert incoming connections” on the Stealth Ports wizard.

How to do this: Hide PC Ports using Stealth Ports Wizard | Internet Security v7.0| COMODO

You may also want to disable “Do protocol analysis” in firewall settings and see if that works

I also recommend unchecking the option “Do NOT show popup alerts” and select “Set alert Frequency level” to Low.

This way you should be alerted before a connection is blocked. If your not alerted, try raising the frequency level to medium.

Thank you for the quick reply.

I have portforwarded my router, so the problem lies elsewhere.

I tried what you suggested and set the Stealth Ports to “Alert incoming connections” and I already had “Do protocol analysis” disabled.

I also tried unchecking the “Do NOT show popup alerts” and even tried to set the “Set alert Frequency level” to Very High, and Comodo still stayed quiet when I tried accessing my server from my external IP address.

And once again, I can connect just fine if I just disable the firewall and try to connect to the server.

I don’t get it, since I have already allowed every connection to the javaw.jar and port 25565 and nothing should be blocking the connection, but still something blocks it.

Do you have any other ideas what could be blocking the connection? And thanks for your time, I appreciate it.

Try using the advice here: Comodo Forum

To create a proper global rule. Also make sure the allow global rule is above the block ones.

I made the global rule exactly like that and it still doesn’t work.

I know this may sound like I’m doing something wrong, since nothing seems to work still after these, but I have checked that I have done exactly like you told me to do, so it’s not that I’m doing something wrong either.

Well, I’m open to any other ideas if you still have any, I’m out of ideas myself at this point.

You can also add Minecraft server port to your port sets

Tasks> Firewall Tasks > Advanced Settings> Portsets

Right click and select “add”

Name “Minecraft server”

Than right click “add” in the box

“A single port” 25565

Also a screenshot of your global rules would help.

Lets see if we can finally solve this problem :slight_smile:

Also, where did you get your minecraft server jar from? Did you get it from Minecraft’s website here:


I hope you know that Craftbukkit was taken down: http://dl.bukkit.org/downloads/craftbukkit/


Sorry I haven’t answered in a while now, but I’m back now.

I took some screenshots so you can see better how my configurations are:
Portsets: Dropbox - Error
Firewall settings: Dropbox - Error - Simplify your life
Application rule for Java, and I have the same for the server jar file: Dropbox - Error
Global rules: Dropbox - Error - Simplify your life
Global rule for Minecraft: Dropbox - Error - Simplify your life
In the Minecraft global rule I have everything else set to “Any”, but have the Destination Address set to my MAC address as it was suggested in the earlier link you sent me.

And Thank you for telling about Craftbukkit, I haven’t looked at their download page much lately, and last time I went to see if there was 1.8 server file up, it still worked fine. And yes I have been using Bukkit earlier. Anyway, I downloaded the Mojang’s own Vanilla server jar file and ran the server from it, and Comodo refused to allow cconnections through it, too. So the problem isn’t just the Bukkit server jar file. I also have the newest Java installed, so it shouldn’t be a problem either.

Just ask if you need some other screenshots or more information.

And also, as you can see from the portsets, I already had it like you suggested, and it didn’t work.

And there’s one other thing I’m trying to solve now, too: After reinstalling Comodo it blocks my Asus Xonar audio control panel software from starting when I start up my computer, so I always have to start it myself. It wouldn’t be a problem, but I’m using a home theater system with my computer and the control panel changes the outputs to the right one so everything works, but if the software doesn’t start, windows doesn’t output the audio to my optical out and I can’t hear sound, so I always have to start the control panel manually so that the audio works. I have set the Application Rule to allow everything for it, but Comodo still blocks it. I don’t know why it’s only now, since it worked before and I haven’t blocked it either.

Anyway, that isn’t so big of a deal right now, I was just thinking of telling this too, if you know what could be up with it. But for now I’ll concentrate on getting the server work with the firewall.

Try changing the Global rule to Direction In and Out, also try setting javaw.exe to use the “Allowed Application” rulset. Also check you unrecognized files under “File rating” and move any files there to Trusted files that you truly believe are safe.

I first kept the Direction as In and Out and it didn’t work, and I read that In should be enough. I’ll change it to In and Out again.

I also have had javaw.exe in Trusted Files all the time now that I checked. And now that I checked I don’t even have any files in Unrecognized Files category.

And I also have tried setting javaw.exe as Allowed Application earlier, but it didn’t work either, so I tried changing the settings a little.

I now changed everything as you suggested, and it still isn’t working. I also tried checking the Defence+ rules to allow Minecraft and javaw.exe and the server .jar file, but it didn’t work, and turning off HIPS/Defence+ had no effect, so it’s the firewall. Just wanted to check, even though I knew it’s the firewall.

Can yo try checking your firewall as I don’t see any issues with Comodo, are you sure you set port forwarding correctly?

As for the Asus Xonar audio control panel software, I recommend running a rating scan and trusting all unknown files, Only if you are sure they are safe.

I know, everything’s been set correctly on my firewall, but still nothing works… That’s what frustrates and baffles me, too and why I came to ask for help.

I have portforwarded the 25565 port corrrectly, too. If I change the port forward settings on my router, no one can access my server with my external IP-address even if Comodo is disabled, but when I have ports forwarded correctly my friends and I can access my server with my external IP-address, when Comodo is disabled.

Here’s some pictures so you can see:
IPv4 address: Dropbox - Error - Simplify your life
Router settings: Dropbox - Error

And it has worked before like this, but now the firewall is blocking the server and I have no idea why.

Anyway, I’ll try the Rating Scan and see if there’s anything there.

Update: I did the Rating Scan and couldn’t find anything Minecraft or Java related, but I did however find asusaudiocenter.exe from the Unknown Files, and added it to Trusted Files, so let’s hope that at least solves the audio control panel problem I told about.

But I’m still lost at the Minecraft part, and you’re probably out of ideas soon, too. I mean, it should work, but it doesn’t.

Update#2: Look what I found from the firewall event logs:

So yeah, Comodo is blocking the 25565 port, even though it is set allowed…

Try editing your forward rules to be TCP 25565 instead of TCP or UDP, as its worded as ‘or’ not ‘both’ only one type will be permitted. Its generally best to separate firewall rules by protocols especially when forwarding.

That wasn’t a bad idea to try, but unfortunately it didn’t work either. I even made another port rule so I now have separate rules for TCP and UPD ports.

You could create a rule for the Windows Operating System. which would only allow connections coming from port “25565”

You can also, Go to “Application rules”

Right click “Add”, than select “Browse”, “Running Processes” Than select the “Windows Operating System” which should be at the top.

Than copy from “another application”, and choose “System”.

Option 2:

Add a custom rule for the Windows Operating system.

Action: Allow
Protocol: TCP
Direction: In
Description: Open ports for Minecraft server.

Source address: Network Zone (Select your Home Network)
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: A single port: 25565

Have fun with your server :slight_smile:

Phew, a lot of hassle, but I gotta say, that got everything working.

So, the case is over. I really have to thank you for your patience and am glad this worked, and now I know what I have to do if I struggle with a similar kind of a problem in future.

Hope this thread may also help others if someone has the same kind of problem.

I’ll be signing off now and going to sleep, it’s night already here in Finland.

Thanks once again.

Glad everything worked out :slight_smile: Those logs really showed what the exact problem was.

Hope anyone who has a similar issue like this will post their logs so that others can know exactly how to help.

hi folks,
i dont want to necro this post, but i have the exact or similar problem
i want to host some servers for friends joining me, terraria, minecraft, and different other games

training mode, safe mode, custom mode all of them work the same in here - means they ignore the “allowed application”

the only way friends are able to join my games is me disabling the firewall for 15 minutes each time somebody wants to join.

in one way this is cool and safe the other way its frustrating that the simplest games as “allowed application” are ignored by comodo itself and dont work properly

is there a simple solution to allow specific applications to be reached and keep global rules on?
ports are forwarded correctly in my router and my games are set up correctly.

my intention is to put them on allowed applications and thats it but it seems that is not possible :cry:

You have to add the port forwards to the top of the global rules as well. For instance I host a personal Teamspeak 3 server. It listens on UDP 9987. Therefore I need a application rule and global rule to allow that inbound connection.

Action: Allow
Protocol: UDP
Direction: In
Source Address: Any
Destination Address: Any
Source Port: Any
Destination Port: 9987

Make sure this rule appears above any block rules in your global rule list.