[Solved] Comodo Dragon Bug - Home page not loading

  1. Symptoms

Set https://startpage.com/ as Home page ( Settings \ On Startup \ Open a specific page )

Close the browser. Relaunch from desktop or quickstart Icon = Home page will not load

Go to another bookmarked web page and it loads as normal pretty much instantaneously.

Thereafter click the Home Button ( also set to https://startpage.com/ ) and it loads without issue.

The set homepage only has trouble loading upon first launching Dragon.

Another user with the same problem reported here https://forums.comodo.com/news-announcements-feedback-cd/comodo-dragon-ver-210-is-now-available-for-download-t85982.0.html;msg615582#msg615582

  1. Steps to try and resolve / troubleshoot

Also installed the same Dragon software with the same setup on three machines;
Desktop Win 7 x64 - Ethernet to router
Laptop Win 7 x64 - WiFi (WPA PSK 256bit encrypted)
Laptop Win 7 x32 - WiFi (WPA PSK 256bit encrypted)

All of the above experience the same problem

Other browsers with the same home page on those machines do not.

Which negates the need to check any further potential problems with my setup, however just in case checked Router block lists ( only a few specific sites blocked in there ), primary and secondary DNS resolver for IPV4 on each machine is set optimally for my ISP, Hosts file in use ( Blocking Unwanted Connections with a Hosts File ) up to date on all machines monthly upon update ( and checked with a default windows empty hosts file ).

Router is setup re-flashed with DD-WRT firmware ( latest for my router - Not a homebrew version )

Also tried the two laptops on another family members Default setup router ( with a different ISP ), and set both machines IPV4 Primary and Secondary DNS resolver to the default of Obtain Automatically while testing in that household. Same problem experienced.

That household also use the same StartPage.com home page … But in Googles version of Chrome which does not have this problem.

  1. Version = Dragon ( Stable )

  2. Plugins / Themes / Extensions

Theme - Robot theme Robot Theme, inspired by Android™ - Chrome Web Store
( Theme only installed on one laptop )

Plugins ( as listed on dragon://plugins/ ) -
Remoting Viewer ( Disabled ),
VLC Web Plugin ( http://www.videolan.org/ ) Enabled
( No Flash or PepperFlash )

Extensions ( as listed on dragon://chrome/extensions/ ) -
ScriptNo ( ScriptSafe - Chrome Web Store ) Installed - Which is set to allow startpage.com
Comodo Site Inspector

  1. Windows Version - As noted in point 2. above per machine

  2. UAC status - Enabled ( all machines )

  3. System Drive - C:\ ( all machines )

  4. Installation path for Dragon - Default setup location ( all machines ) set by the manually downloaded installer available here Best Internet Browser 2022 | Free Secure Web Browser ( auto update is notify only, I manually update with the downloadable installer when ready to update )

  5. User privileges - Admin ( all machines )

  6. Google Chrome not installed. Comodo Dragon is the default browser ( all machines )

  7. Other information …

Comodo secure DNS ( as offered in the Dragon Installer ) not being used.

Search engines installed - StartPage HTTPS Startpage - Private Search Engine. No Tracking. No Search History.
All other search engines in settings deleted

Privacy ( “Advanced settings” <<-- Why aren’t these at the top in BOLD instead of googles hidden away from the user default )
Checked the following ( No other items selected ) : …

Do not allow websites to know where you came from ( Referrer supressed )
Enable Phishing and Malware Protection
Offer to save passwords
Network is default ( No proxy setup )
Offer to translate
Check for Server Certificate revocation

Further Content settings : …

Keep Local Data only until I quit the browser
Block Third Party cookies and site data
Clear History when I close my browser

Images / Javascript / Handlers = Do not allow

Plugins = Click to play

The rest thereafter are all = Do Not Allow

Web Intents Unchecked.

And - Probably un-related but strange all the same - The mysterious Allow websites to use your WebCam / Microphone setting (which I only saw once, it has disappeared off the settings page since) = I tried to turn it off the first time I saw it, but the switch button did not seem to work, since then after looking at the settings after re-loading the browser - That option does not exist anymore ???

A bit strict, but I like to allow each element per site individually as opposed to the default across the board allow for useability some settings.

Lastly: On the Flags page ( dragon://flags/ )

I have enabled Disable Web GL ( the switch now reads Disable; confusingly :slight_smile: )

I have not changed any other flags currently.

Edit: NB

For StartPage.com I do allow exceptions for cookies, images and Javascript

Son of edit:

No third party firewall - Windows firewall is turned on, all machines up to date with windows updates

Microsoft Security Essentials is my only active anti-malware ( with MalwareBytes Antimalware non resident as an occasional ( once per week ) manually update and run as required second opinion )

Background services very minimal windows only, no third party ITunes mess of services for instance.

No silverlight, and I refuse to accept Microsoft Bing as an “Important” update :slight_smile:

Revenge of Son of Edit:

Not sure if this is worth mentioning but I also kill the following on Windows 7 …

Universal Plug and Play service (UPnP)
( See DCOMbobulator and UnPlug n’ Pray ( right click and run as admin on win 7 ) - Here Most Popular Freeware on GRC.COM )
By the same guy who programmed Spinrite and DNSBench, Steve Gibson

( Note for casual readers - There are quite a few of those utils at the last link not written for Win Vista or 7 )
Mod edit: Added solved to title, Captainsticks.


Used the downloadable installer (on 2 machines), and one machine used the auto-update.

Installed version

Still experiencing the same problem.

Although immediately after installing this new version, on first run my https://startpage.com/ homepage loaded instantly.

But only on the first run of Dragon. After closing the new version of Dragon, and reloading, the home page not loading problem recurs.

Tried again on the desktop, and both laptops. Same for all machines.

All installations here were overwrites of the previous installation.[/s]

Guys - Scratch the last post :slight_smile:

Just on a hunch decided to do a clean install

Exported bookmarks first to a html file

Completely un-install previous version, ■■■■ cleaner to route out any remaining registry fluff (there were a few)

Checked hidden folders (appdata etc) for any leftovers - Actually your un-installer is pretty efficient in this regard …

Re-install and setup as usual with the downloadable installer

Got comfortable again with all usual settings, un-installed that share extension, disabled Remoting viewer etc …

Result = No more problems with the home page. I believe it was probably something left behind at each install overwrite which created my problem.

This is an ex bug :), @ Moderators this can be closed.

I also had the above issue and have done a clean install for a different reason, but a clean install solved this for me also. :-TU

Hi w33d3r,
Thanks for your time with this issue, topic now closed. :slight_smile: