[Solved]CIS Version 3.8.64739.471 and later crashing sound driver on HP notebook

Clean install of CIS 3.10 worked :smiley:

When I install or update to Version 3.8.64739.471 : 19th Feb, 2009 Version 3.8.64263.468 : 12th Feb, 2009 or later, an error occurs within the drivers for my Laptop speakers (HP Pavilion).
I am using Windows Vista Home Premium 32bit SP1 (:-[), 64bit CPU, and “IDT High definition Audio CODEC” as sound driver and “Quick Launch Buttons” as input/control device.

When I install (or update to) CIS 3.8.6439.471 3.8.64263.468 or later, and restart my laptop, my Button for muting/un-muting the sound does not longer change colour to “activated”, and the integrated subwoofer is the only speaker which works. This does however not affect line out or similar.
UAC does not affect this error, so does not anything in the configuration of CIS. Both Administrator and restricted accounts suffer from this error. Activated security Applications: “Avira Antivir” & “Spybot Search&Destroy”.

  • Note that every thing is fine until I restart the computer to finish the setup. When I uninstall CIS, everything is fine again.
  • When I reinstall the sound driver (while CIS is installed), and cancel the setup before the button changes colour to “deactivated”, the subwoofer stops to work and the button does not change to “deactivated”. However, the two other speakers are working perfect.
  • When I uninstall CIS and reinstall it without restarting between, the sound works from the installing until the second restart after this. After the first restart, CIS detects a faulty installation and asks (after repairing) for a restart.

Therefore I assume that the error is something which gets activated after the restart of the computer.

  • Please note also that ALL(!) versions from until 3.8.64263.468 3.5.57173.439 Worked Perfect, so therefore the problem must be hidden in one of the changes done from 3.8.64263.468 to 3.8.64739.471 3.5.57173.439 to 3.8.64739.471 .

What I have tried to resolve it: Reinstalled sound drivers, rolled back to the previous version, updated the sound driver, reinstalled CIS, with and without components as anti virus, contacted HP and submitted a support ticket. I will re-contact HP today, to confirm that the Problem was not caused by Damaged Hardware.

Some Kind of !ot!:
Could please someone be so kind to give me a link to version 3.8.64263.468, because I only have an installer for version (and the versions which doesn’t work…), and am therefore forced to use this Version :cry:

THX Dennis

Clean install of Version 3.8.64263.468 does not work either. I suppose that I either have missed this update or made a mistake here. Anyway, I am sorry for giving you wrong Informations :-[
Version numbers in my post are corrected.

Please try here
Have you tried the 3.9 version?

Of course I have, I wouldn’t had bothered to write all this if the problem had been solved :wink:

Thanks for the link and this quick response! (V)

[EDIT] where are my manners? Happy Pentecost, Whitsun, Whitsunday, Whit Sunday, Whitsuntide or whatever you may call it!

Problem Resolved!
Version 3.10 did the trick!
I can only thank all people who where involved for their good work, and saving me from using another firewall :stuck_out_tongue:

Thank you very much for confirming! :slight_smile:

I will go ahead and close this thread.