[Solved] CIS doesn't show any connections


I’ve just update Commodo Internet Security to (nice new GUI btw), it seems to work well, but I think I found a bug.

1: CIS version:
2: OS version:
Windows 8.1
3: What you did:
See the picture below. I clicked on both, incoming and outgoing connection buttons
4: What you actually saw:
the new active connection window opens, put it’s completely empty. As you can see below the mentioned buttons, there are some connections being monitored, so I think the monitoring does work (well, I deeply hope so).
5: What you expected to happen or see:
Like in the last version, a list of detailed information .
6: If possible attach a screenshot illustrating the GUI problem
here you are:


The same here. Can’t see any active connections anymore where they used to show normaly…

Is this a bug?

I have Windows 7 - 64




No problems here. Win7x64 and CIS 6209. Try to reinstall.

Same situation. Windows 10 Pro 64 bit - CIS
Clicking on Inbound / Outbound only an empty window appears.
The same behaviour when clicking on “blocked applications” or “unrecognized files”

Exactly the same here.

These two do appear to be working for me.

I did clean install and everything works fine now. I see te active connections now. :smiley:

Thanks, I was going to give that a try, but it requires that I uninstall my existing version of Comodo Firewall first. And when I attempt that I get:

“COMODO EndPoint Security Setup ended prematurely because of an error.”

What the hell do I do now???

Is there a removal tool available?

Maybe you can try to uninstall in Safe Mode?
Or with CCLeaner uninstaller?
Otherwise I don’t know…

Normaly, if something happens and nothing works, I throw away every Comodo-folder I can find with Windows Search, than I clean the registry with CCleaner, restart and after that I try to install the new version.

Sometimes you can try to install without uninstalling you existing version first.
Or if you have the old setup-file (.exe) you can try to install it again, sometimes you get the option ‘repair installation’ and after that you try to uninstall…

Thanks, I tried that, and got a message part way through installation that I’d need to manually uninstall my existing installation and try again.

Trouble is I now appear to have v10, for which I don’t have a setup file.

This is CIS :

If repairing works, and you see active connections afterwards, you don’t have to uninstall CIS, off course, but a clean reinstall solved my problem with the active connections, whatever it was.

Installer is located under: %ProgramData%\Comodo\Installer

Thanks, but as I mentioned in an earlier post, I’ve already tried that. All it does is install Dragon Browser and GeekBuddy (neither of which I want) and then inform me that it can’t uninstall my existing Comodo Free Firewall, and I’ll need to do it manually, then try again.

Thanks I’ve found cis_setup_x64.msi at that location, but it’s dated 2013 so is presumably for a (much) earlier version. Presumably, now I appear to have v10, it’s not sensible or safe to run that?

Did you perform update or clean install?

An update, though it appeared to get stuck before finishing and I had no choice but to reboot. It appears to be mainly working (as v10), but some things are not quite right, like the inability to view connections, and the inability to uninstall.

Then try a clean install as someone else said it fixed their issue when they performed the clean uninstall/install follow this guide.

Thanks, but as I have mentioned previously, uninstallation via "add/Remove Programs’ doesn’t work, I get “COMODO EndPoint Security Setup ended prematurely because of an error”. Can I safely omit that step and just run the ‘removal tool’? (I suspect probably not…?)

Endpoint security is for businesses that use a security manager. Are you on a company owned system or is this your own personal computer? You can try the removal tool but you may not have the permission to remove endpoint security. You can check the installer log in the %temp% folder and look near the bottom for the error reason.

My own personal PC.

The only things I can find in there is a ‘Comodo LogsFolder’ containing ‘dragon_setup.log’ and ‘generate_dragon_uninstaller.log’. There’s also ‘cmdinstall.exe_17-04-11_13.39.18.log.7z’ which contains a pretty short (35 line) log file which doesn’t list any errors.

what happens if you run the CIS .msi installer that you found earlier? It should give you the option to repair or uninstall.