[SOLVED] Can't reinstall CIS

I have Windows 7 x64 and CIS installed in July 2011. Last month it reported every day that there is new version and I must reboot PC to install it. After reboot nothing happens, it just still keeps saying, that I need to reboot my PC. So I tried to completely remove CIS and reinstall it but uninstall fails with message about network error at reading c:\windows\installer\cis_setup.msi. I found this thread https://forums.comodo.com/install-setup-configuration-help-cis/cis-cfw-t69078.0.html;prev_next=next then I run Microsoft Clean Up Tool and removed CIS, then reboot to safe mode and run Comodo CleanUp Tool. After reboot I have error like “cfp.exe is not being started. It must be started from this path” with empty path. I run installer of new CIS, it says I must reboot my PC. Ok, I rebooted, installer did something to 4% and says again that I must reboot. After reboot again installer did smthing to 7-8% and says about reboot. Finally after third reboot it show this message at 12% :slight_smile: I think it’s not right installer’s behavior, so how can I clean my windows and install CIS?
I also attached installer log and report of diagnostic tool, it says that it can’t fix the problem.

[attachment deleted by admin]

Please try reinstalling CIS by following the advice in this topic. Let us know if you run into any more problems.


Thank you for help, but I still can’t install CIS.
Revo uninstaller and other uninstallers just can’t find installed CIS.
Jacob’s Uninstaller Tool didn’t help. I tried it in Safe Mode and in normal boot (both times run as admin).
Also I cleaned registry and file system with Comodo System Cleaner. Nothing changed. I still have error message after windows loading and installer ask to reboot.
I tried to make logs like it explained here. DebugView makes empty logfile. I’ll attach CIS installer logs. First is after installer run and second is after reboot.
Also here is error message that I have after windows loaded:


[attachment deleted by admin]

Try downloading Autoruns and disablign all entries related to Comodo. Then restart your computer and try the other processes again.

This may help as it could be that part of the self-defense is still active.

I disabled CFP.exe ang both guard dlls (guard32 and guard64). Nothing changed (of course, error message about cfp.exe has disappeared), installer still trying to remove CIS (as it says in log file) and ask to reboot :embarassed:

I found node in registry HKEY_LOCAL_MACHINE\SOFTWARE\ComodoGroup\CDI\1 which has 3 parameters with Product Name, Version and old Installation Path. I’ll try to remove this node and run installer again. Hope it’ll help.

It works! After removing this registry node CIS has installed without any problems!

Hello xV1RUSW0rm

Thank you for your findings I’ll update the scripts in the Tool as soon as possible