[Solved by reboot] Comodo randomly started blocking traffic without alerts

You can skip this part (jump to question part at bottom of this post):
Im searching firewall for me and first my attempt is comodo.
More i try to use it, more problems i have.
For last 2-3 days comodo is not showing me any windows about any unknown traffic.
Silent mode is off, “Do not show popup alerts” is not checked, “Set alert frequency” is “Very high”.
So no alerts, i thought everything is good and there is rules for everything.
But today like 30 minutes ago websites stopped to work randomly. Browser was unable to resolve IP.
So i tried

>nslookup google.com DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds. DNS request timed out. timeout was 2 seconds.
Okay. If there is no popup window then it means there is rule created blocking DNS. So i pressed bugged [i](in my opinion)[/i] "silent mode" button just to see if its unpredictable behavior will help. And all resolves started to work. And as we remember from my last thread https://forums.comodo.com/install-setup-configuration-help-cis/quiet-mode-allows-everything-even-handmade-delphi-application-t119763.0.html "silent mode" has catastrophic behavior [i](in my opinion)[/i] that not only allows all traffic but even creates rules for it. But then why when i disable "silent mode" all my DNS resolves stops working again. That means no rules was created. At this point i think that nobody at comodo knows how this "silent mode" should work and how it works.

My question is:
I made small application that downloads “http://google.com” and it failed with “Error: connect ETIMEDOUT” without any popups from comodo.
How to get my popups back?

*Everything in this thread can be completely wrong and all my problems can be because i do something very stupid. But i can’t find what.

Just in case, here is screenshots of my settings
Alerts/popups enabled, but i don’t see them when i launch application that wants access internet and doesn’t have rule.

Okay, if anybody curious here is additions to my story.
Turning on “silent mode” freezing comodo window, and it feels like every day freeze time is increasing.
Yesterday it was 54 seconds.
But today comodo window was minimized, i attempted to maximize it and it freezed for about 5 minutes and then maximized itself.
And after that clicking “silent mode” is not freezing anymore.
Opening settings window, twice clicking on some option (to enable and disable it) and clicking “OK” was causing same freezing (i think its same). I did not recorded that freeze time yesterday, but today it is 79 seconds.
I need to wait 79 seconds before my settings window will get closed.
Feels like there is some kind of leak that increasing freezing day by day.
In my “Settings->Firewall->Application rules” i have 29 applications and total of… It hard to calculate exactly amount of rules.
When i click “+” near all 29 applications my scroll bar becomes very tiny. Scrolling 10 pixels is 53 lines of rules.
Total is 582 pixels so its about 3000 garbage rules created by “silent mode” for p2p applications that connects to random IPs. Actually i didn’t know some of those applications are p2p (like steam for example, he has more than 200-300 rules)
After replacing created rules with single “allow everything for this application” rule, pressing “OK” in settings taking only 4 seconds to close. Thats good now.

Main question: Did i got my popup/alerts back?
I still have no alerts/popups for unknown applications, comodo just blocking them.
So i tried ultimate fix for bugged/unstable software - rebooting PC. Usually i do this once 2-3 weeks.
And oh my god, my alerts/popups got back. Everything works again!

In conclusion - if you found this thread in google i can say:
If you need to protect some very important PC then do not use comodo. It is like in alpha/beta stage. Maybe later when all bugs will be fixed it will be better, but currently (version it is unstable and unpredictable.
And if you have some problem, try to reboot your PC. It helps with comodo. Sad but true.
*and never click “silent mode” button. Its suicide button. Read my previous thread.

Additionally to all problems i had with comodo, this happened.
I was playing games and this randomly happened.
Looks like everything still works, but this software not feels like very good quality…

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <TimeCreated SystemTime="2017-06-18T23:59:53.000000000Z" /> 
  <Security /> 
- <EventData>
  <Data>C:\Program Files\COMODO\COMODO Internet Security\cis.exe</Data> 

Please attach diagnostics data.
(main interface window > question mark (?) > support > diagnostics)

It generated 522mb zip file. Not sure what is stored there so i sent it to you in private message.

Seems like alertsUI is crashing for some reason. That’s the issue you’re experiencing (crash => alerts are not displayed => blocked traffic due to no response). I’ll report the issue.


// bug 2272 + bug 1799