[solved]Annoying "threat detected", in red color, on top of Widget...

Hello all,

Since installation of last CIS premium release, because my choice was, before, not use comodo antivirus but ESET nod32 (up to date) and remains the same, at this moment, I’m annoying by the message (on top of widget) saying that a threat is detected. When I open the main cis window, there is, either, the red banner saying me that antivirus is no activated and propose me to correct this… I suppose that cis is not able to detect that I’m currently using a third party antivirus !

Let me give an history of my installation (and, in advance, I appologize for my english which is not my first language :-).

I bought my PC in 2010 and made a clean installation of windows 7 home edition 64 bit. I made the choice to install both commodo personnal internet security suite and ESET nod32 (I have been using it for a while, with an official license). Everything was well and no problem detected. My configuration was to use comodo FW+HIPS and ESET nod32 antivirus+HIPS (well, I know that it is not recommended to use both HIPS but it seems that they don’t act inthe same way, I would say both seems to be complementary… This is not the subject of this post). So everything were OK and comodo cis status was OK, no threat detected, I’m protected. The same as ESET NOD32 AV.

I subscribed for Windows 10 home edition x64 free upgrade, as proposed by microsoft, a couple years ago… Migration process were quite clean and as far as I remember, I decided to upgrade to the last commodo CIS, at this time, and it was release 8… I rember the upgrade failed so I completely uninstall CIS to proceed to a clean installation (after registry cleaning)… Well, at this moment everything seems to be OK. But since a new weeks, I encountered problems with CIS upgrade to CIS 10 (from my current release which is 8.x.x. - i don’t remember) which was stuck at 81.6 % of installation progress (and 91% of global progress). So, each time I had this problem, I decided to restore a previous image of my system (generally, I use to make an image every week) and to wait the next time the upgrade is proposed. But always the same ! So recently, I decided to completely uninstall comodo, it was a bit tricky because I was oblige to use some deep uninstallers associated with comodo removal tool (from this forum) to get rid of commodo and to be able to do a fresh reinstall, using the interim offline installer available here…

Everything is now ok and both CIS 10 and ESET nod32 are fully protected, except that CIS 10 does not see that I am already protected with NOD 32 A/V . Note that I have not received any notification from Windows 10 Security Center on that point, since installation is complete.

So my question is : is this an issue with CIS 10 ? A configuration problem ? Or a normal behaviour, which is not to consider as normal to not activate antivirus ?

Sorry for the long post but I wanted to give the more informations as I can to help you in your analysis.

Best Regards

You should remove the anti-virus of CIS by going to programs and features and selecting comodo internet security then click change/remove. Once the Comodo installer window appears select change and un-check comodo anti-virus, processed with install, reboot when finished. For future reference you want to download the cfw installer.


thank you for your answer. Effectively, I was just reading the documentation and I saw this point. However, during installation using the offline installer, I was not able to install only FW (because no select box for AV), I was wondering if the procedure you mentionned will be applicable in that case…


Ok great !
Thank you very much ! Have a good day…


Hello again,

My previous topic was flagged as “solved” but in fact it is not.
Here the link corresponding to the previous topic : https://forums.comodo.com/install-setup-configuration-help-cis/solvedannoying-threat-detected-in-red-color-on-top-of-widget-t118945.0.html

Back to home I made an image and I tried to modified/change the setup, in order to deinstall Comodo Antivirus. In fact, the option Modify is in grey, I cannot modify… The only possible action is to Uninstall !

I suppose this due to Interim Offline Installer… Is there a clean workarround or a registry key to modify, to be able to click on modify and to be able to select Comodo A/V to be uninstalled ?

Thank you in advance.

Use control panel > programs and features > Uninstall/Change. I don’t know why Windows blocks the modify button.

I agree, but apparently the offline installer (called interim on this forum) is built such a way that modify/change is not available. Just for information, I installed (offine) CIS Premium 10 as a Super Admin (with out UA limitaion)…

Actually I just tried and when you click the uninstall button in apps & features the comodo install window shows which gives you the option to repair, change, or uninstall.

Yes you right, just did the process… Let me give you feedback when completed :slight_smile:

Great great great !!!

Thank you so much ! Yes you did :slight_smile:

You sorted out with my situation ! You can flag my post as solved.

Thank you for all comodo community