Slow on SSL pages, and logo doesn't show on https

OK this is an odd one, so bear with me. :slight_smile:

When the trustlogo code is on our site it works fine with http. The logo shows and there is no slow down in the pages loading.

The problem is with SSL pages. When clicking a link which takes you to an SSL page (checkout), the page is slow to load and the message in the lower browser bar is “connected to secure.comodo.net”, and the page loads slowly. When the page has loaded there is no trust logo, yet the SSL cert padlock shows complete, as it should.

When i remove the trustlogo code, the SSL pages load up quickly.

Any ideas? I’ve tried with support, but either they are not understanding the problem or they are saying there is no issue with connection. The fact that it loads fine with http, could mean it’s code related and not connection related. The code however is as generated by the instructions on the comodo page regarding trustlogo installation.

Hi,

I spoke with our server team and there are no issues with the server serving Trustlogo details.

Please provide the ticket number in your reply and I will see if there is anything support have found.

Garry

#HIF-687806

the site is http://www.oyyy.co.uk if you register and place something in your cart, then checkout you’ll see what i mean. :slight_smile:

Not trying to complain about support btw, just trying to work out the problem. :slight_smile:

edit

Just noticed that the delay isn’t anywhere near as bad in IE as Firefox. The logo however, doesn’t display on an SSL page in either IE or Firefox.

Any ideas on this?

It would be nice to get rid of the delay.

Hi,

I have tried with both IE and FF.
Adding something to the shopping cart, then proceeding to the checkout.
Both load the page instantly, ie no delay.

And I do get the logo when I do this.

I even tried this with a newly installed machine, just in case there was any caching, but again it loaded instantly on the SSL checkout page.

Unfortunately I cannot see the issue you describe.

One thing I did notice on the new machine is that the padlock disappears on secure pages, which suggests that graphics are being called over http and not https.
I would suggest changing all references to graphics to full URLs including the https so that they are called securely.

Garry

Hi,

Thanks for your reply.

I think the problem is with our router/network settings as i too can see the logo from a different connection.

I also noticed the padlock dissapearing on IE, though it stays on firefox. All the images are called using “folder/image.extension”, so should work for https and http. As our https is calling from the same folders as the http. (:WIN) I’ll have to look into that. I did notice that on the secure pages (checkout and account), although the padlock doesn’t appear it doesn’t ask you about secure/non secure content as it should do.

An example is https://www.oyyy.co.uk does give that message as it’s not setup to be used as a secure page.

edit

Found the offending image. :slight_smile: It seems that there was a https link which although the link was https, the link wasn’t content. It had been changed from http to https just on the offchance their ssl was the same location as the non ssl content. So i’m now waiting for an SSL located image link from them.

Thanks again