Slow file transfer in MSN Live Messenger

Hi, I have a problem with slow file transfer in MSN Live Messenger, version 8.1 (newest at the moment, as far as I know). I have Comodo Firewall Pro 2.4.18.184.

When I send a file to my friend in Messenger, the file transfer is very slow. When I shut down Comodo, and try again, it is much faster, maybe 5x faster?

I have marked MSN Live Messenger trusted through “Define a new Trusted Application”. It doesn’t seem to work.

So, what should I do, change Comodo to another firewall software??? Please, give simplified answers as I’m from Finland and not perfect in english!

Big thanks for your help!

Welcome, Bugsu!

Take a look a this thread: https://forums.comodo.com/index.php/topic,4680.msg45982.html#msg45982 from that point on I think we were starting to get somewhere, maybe. Prior to that I don’t think we accomplished much. Unfortunately, Ingro never followed up to let us know how things went with the Services.

The key thing is that at least two users reported they use MSN Messenger Live without any issues or special rules. it should work just fine. We know it utilizes some Windows Services (for instance MS says UPNP has to be on), so there may be something there.

LM

I’m also having problems with slow transfers on MSN and I think it’s due to Comodo, I haven’t changed any settings and allowed everything I’ve used so far as I’ve only recently installed Comodo.

Does it have anything to do with this blocked item on my list?

http://sixpop.com/images/file/41145239.bmp

I’m using the latest Windows Live Messenger. Beta.

Leiche,

I can assure you it has nothing to do with that Block & Log All rule - please don’t think you have to remove the rule… :wink:

You should not (in general) need to make any modifications to the Network Rules; the only place changes should need to be made, in order for MSN Live Msgr Beta to work will be Application Monitor.

It is possible that the application is trying to generate traffic in such a way that it uses IP Protocols not allowed by the Network Monitor. Here’s the thing to do, to test that.

Close All internet-connecting applications (browser, email, IM, etc). Go to Activity/Logs. Right-click an entry and select “Clear all logs.” Now open Only MSN Live Msgr Beta, and attempt a file transfer. What we want to do here is fill the logs only with the entries related to the slow transfer. If Comodo is blocking something here, it will be in the logs. Once the transfer is complete, go back to Activity/Logs.

Right-click an entry and select “Export HTML.” Save the file and reopen it (it will open in your browser). Highlight the entries (if there are a lot, just highlight 10 or so, that correspond time-wise to the transfer). Right-click and Copy the highlighted entries, then Paste them into your post here. (If your external IP address is in the logs - it will match the IP shown in the lower-right corner of your posts here - you may mask or edit it with ‘x’ for privacy.)

LM

COMODO Firewall Pro Logs

Date Created: 19:47:59 10-07-2007

Log Scope:: Today

Date/Time :2007-07-10 19:47:33
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 82.143.158.140, Port = 10000)
Protocol: TCP Incoming
Source: 82.143.158.140:51784
Destination: 82.32.58.127:10000
TCP Flags: SYN
Reason: Network Control Rule ID = 5
In the attackers’ world, this port is usually used by Trojan.W32.dumaru.ad(10000)

Date/Time :2007-07-10 19:47:28
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 82.143.158.140, Port = 10000)
Protocol: TCP Incoming
Source: 82.143.158.140:51784
Destination: 82.32.58.127:10000
TCP Flags: SYN
Reason: Network Control Rule ID = 5
In the attackers’ world, this port is usually used by Trojan.W32.dumaru.ad(10000)

Date/Time :2007-07-10 19:45:23
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 24.64.74.164, Port = 1028)
Protocol: UDP Incoming
Source: 24.64.74.164:7900
Destination: 82.32.58.127:1028
Reason: Network Control Rule ID = 5

Date/Time :2007-07-10 19:45:23
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 24.64.74.164, Port = 1027)
Protocol: UDP Incoming
Source: 24.64.74.164:7900
Destination: 82.32.58.127:1027
Reason: Network Control Rule ID = 5

Date/Time :2007-07-10 19:45:23
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 24.64.74.164, Port = 1026)
Protocol: UDP Incoming
Source: 24.64.74.164:7900
Destination: 82.32.58.127:1026
Reason: Network Control Rule ID = 5

Date/Time :2007-07-10 19:45:23
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 206.192.124.22, Port = 5900)
Protocol: TCP Incoming
Source: 206.192.124.22:42706
Destination: 82.32.58.127:5900
TCP Flags: SYN
Reason: Network Control Rule ID = 5
In the attackers’ world, this port is usually used by Trojan.Backdoor.Evivinc(5900)

Date/Time :2007-07-10 19:44:48
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 82.157.254.7, Port = 5900)
Protocol: TCP Incoming
Source: 82.157.254.7:3094
Destination: 82.32.58.127:5900
TCP Flags: SYN
Reason: Network Control Rule ID = 5
In the attackers’ world, this port is usually used by Trojan.Backdoor.Evivinc(5900)

Date/Time :2007-07-10 19:44:43
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 82.157.254.7, Port = 5900)
Protocol: TCP Incoming
Source: 82.157.254.7:3094
Destination: 82.32.58.127:5900
TCP Flags: SYN
Reason: Network Control Rule ID = 5
In the attackers’ world, this port is usually used by Trojan.Backdoor.Evivinc(5900)

Date/Time :2007-07-10 19:44:38
Severity :Medium
Reporter :Network Monitor
Description: Inbound Policy Violation (Access Denied, IP = 82.157.254.7, Port = 5900)
Protocol: TCP Incoming
Source: 82.157.254.7:3094
Destination: 82.32.58.127:5900
TCP Flags: SYN
Reason: Network Control Rule ID = 5
In the attackers’ world, this port is usually used by Trojan.Backdoor.Evivinc(5900)

End of The Report

My MSN also seems to lag alot due to Comodo, the messages don’t get sent to me for ages from other people. (:SAD)

According to some quick reading, if you’re wanting to transfer files Inbound you will need to create some Network rules to allow traffic through that Monitor. This is supported by the multiple Inbound block entries on multiple ports.

Apparently MSN Msngr uses dynamic port assignment; that is, it will keep searching for an accessible port - you cannot assign one directly in MSN Msngr apparently, and have it stick (you could try to see if there’s a place to assign ports within the application itself; that would be preferable).

Specifically for File Transfer, MS recommends opening (ouch!) ports 1025 - 65535 for both TCP & UDP in order to ensure access (to whomever might want it, I guess…).

My suggestion would be to pick a specific port fairly high in the range, that’s not likely to be used by other applications or exploits (like, say, 43247 or something off the wall like that).

In Network Monitor right-click Rule ID 0 and select Add/Add Before. Build the rule:
Action: Allow
Protocol: TCP/UDP
Direction: In
Source IP: Any
Destination IP: Any
Source Port: Any
Destination Port: 43247

Make sure your Application rule for Msngr is set for Inbound as well as Out, for both TCP & UDP protocols. If you want to create separate In and Out Application rules, and set the In rule to Destination Port 43247 (as per our example) that would be fine, and helps add a little more security.

If you can configure MSN Msngr to use a specific port for Inbound traffic and get rid of the dynamic aspect, that would be even better. Then just match up that port through your rules…

Hope this helps,

LM

Thanks for the help, apparently there was a problem with servers and MSN and it was affecting my other friend, so I’ll see if my transfer rate is okay when I get home tonight. Thanks again.

No problem. Let us know how it goes.

LM

I’ve done what you said but it seems to still be very slow when sending and receiving files. This defiantly needs to be sorted out or have a solution…

Leiche,

Will you file a ticket with Support on this issue? http://support.comodo.com/ Be sure to provide them a link back to your post here so that they know the steps taken thus far.

There should not be a need for any additional rules, AFAIK. In fact, given that other users have not needed to add any extra rules to get the application to work, I don’t understand why yours is not working properly.

Support will be able to provide more detailed assistance to resolve the issue; keep us updated of their response and the solution.

Tnx,

LM

Okay thank you, I have submitted a ticket. :SMLR

One other thought I had, just in case…

Since you added those Network Monitor rules, have you rebooted? If you haven’t, it might help - it would be worth a try.

LM

I haven’t rebooted with those rules, however apparently CPF should work with default settings so I would like to know why I’m being affected.

Please go through the following link to trouble shoot your issue.
https://forums.comodo.com/help/slow_file_transfer_in_msn_live_messenger-t8073.0.html
Regards
Stewart
Technical Support

Might try the reboot. As to why you have problems and others don’t, I do not know… It may be specific to your configuration somehow (hardware, software, etc), or it may just be something from the OS that is a little out of whack. Support should be able to help out with that, for some details to check.

However, I see it looks like they’re just referring you back here. They did that to me once, as well. (:AGY) You may log back in on Support and access the ticket; then reply to it from there. You may want to point out to them that you’ve already been in this thread, and that no resolution is available there. You are not using a Beta product, and require the detailed assistance that only they can offer; tell them that a Moderator referred you to them.

Hopefully that will help.

LM

It’s been a few days and they haven’t replied. ???