Silverlight does not work, despite of being flagged as safe

Hey everyone, newbie calling.

So far, I love Comodo and all its features. But there is a problem that is freaking me out. Everytime I want to watch a movie with VoD on Lovefilm I get an error like “the video is currently not available” or something. I tried different versions of Silverlight, without success. I (think) I gave Silverlight all the rights in the Comodo settings, but the problem is still there. Maybe there is a special .dll of silverlight I have to take care of?

The problem occurs with Firefox as well as with Chrome or Opera.

Do you have any suggestions?

Thanks in advance!

Normally you would not need additional rules for running a plug in. Do you have a custom policy for your web browser? Are you using the Comodo DNS servers?

What makes you think Comodo is interfering?

No, I don’t have a special rule and I also don’t use the Comodo DNS servers. The problem only occurs on this computer and only on this computer Comodo is installed. I thought there might be a relation.

Is the message “currently not available” the only type of error message you get? Can you check in Silverlight settings that there are no pages blocked to belong to Lovefilm. What version of SL are you using?

To quickly see if the firewall part of CIS is involved temporarily disable the firewall. That can be done easily when right clicking on the CIS tray icon and disabling the firewall from there. When using v5.x don’t forget to enable the firewall again. CIS v5.x will not remind you after a number of minutes; version 6 will.

Can you pots screenshots of the Firewall logs and Defense + logs? What version of CIS are you using 5.1x or 6?

Are these problems with or without the sandbox?

@ EricJH: I am using Comodo Firewall 5.x.

I always get the same message: “currently not available”. The settings of Silverlight don’t say anything about blocked pages, on the contrary, Lovefilm has a permission.

I also tried disabling the firewall, but that was of no use. So maybe it isn’t Comodo after all? On the other side, I think that even a disabled firewall has some settings deep in the system that are not affected by that action.

The log doesn’t say anything about lovefilm or is that not listed explicitly?

@Radaghast: I didn’t run the silverlight.exe in the sandbox, if that is what you are saying.

I was thinking more about the browser running in the sandbox. However, I’m not seeing any problems, at least with firefox. It also shouldn’t be necessary to create any special permissions for Silverlight.

As a test, to make sure the firewall is completely disabled, you can uncheck the driver on the properties of the network adapter.

If you’re running Windows 7/8 it’s probably worth making sure the Windows firewall is disabled. Also, disable any additional security applications you may be running for the test.

[attachment deleted by admin]

Thanks for the driver advice. Unfortunately, it didn’t help neither. Windows Firewall is deactivated as well. So maybe it really isn’t Comodo’s fault.

Have you tried using the player on any other sites?

Ok, now I could identify the problem: I am using Windows 7 and the system is on a SSD. I moved the temp folder to another partition and THAT is what Silverlight does not like (Silverlight is automatically installed on the system partition).

Well, that’s it. That brings new problems to light, but at least it has nothing to do with Comodo. Thank you guys for your support.

I’m glad you managed to resolve it. Thanks for letting us know :-TU