I’ve been watching the progress of CPF for a while now and installed the latest version this weekend. Great job, well done.

However, immediately I noticed that it affects the shutdown and restart procedure.
My system is Windows 2000, SP4, all latest updates.

What I should get when restarting is “Shut Down Windows” dialog which asks the question “What do you want the computer to do?”.
If I select Restart, I then get “Log On to Windows” dialog. I again select Restart.
I then get, again, the “Shut Down Windows” dialog. Selecting Restart again starts the Restart cycle and the computer reboots.

When CPF is running I don’t get the “Log On to Windows” dialog after the first “Shut Down Windows” dialog. I get a brief little window that tells me it is shutting down and then a change of resolution to 640x480 and the “It is now safe to turn off your computer” dialog.

This happens if I chose Shutdown or Restart. If I chose Restart, it will not enter the Restart cycle.

I get this even if I quit CPF in the taskbar beforehand.

Previously I used Kerio PF and didn’t get this.
I don’t have this problem if CPF is not running (that’s cmdagent and cpf).
I don’t see anyone else here with a similar problem.

Any ideas?

I’m also a W2k user. But, I’m a little confused by your post… So, before installing CPF when you selected shutdown or standby then your system always restarts? But, that’s wrong… W2k shouldn’t restart when shutdown or standby is selected. It should only restart when reset (restart) is selected.

Since, installing CPF… now nothing restarts… and it all acts if shutdown was slected. Is that right?

I’ve not seen this on my system with CPF & shutdown has always… shutdown (even before I had CPF).

No, sorry, I didn’t explain well. When I clicked on Restart it restarted but now it doesn’t. I’ll edit my original to sort out the confusion.

What I get now for shutdown and restart is the “It is now safe to turn off your computer” dialog. I’ve never had that before in all the systems I’ve created. WHat I used to get is the logon dialog where I am presented with the choice to shutdown, restart or standby. I don’t get that now.

Hope that helps.

Ooo errr. I think W2k might be broken. That doesn’t sound right at all. It will need one of the Comodo CPF people to confirm that CPF couldn’t do this (which I don’t think it could).

Have you installed anything else recently, aside from CPF?

Also, just to confirm… when you hit CTRL-ALT-DEL & select “Shut Down” you do not get further dialogue… it just shuts down (as if you had selected shutdown from that secondary dialogue). Is that right?

This should be related to something else. I have no idea why such a thing can happen though.


Not quite, I do get the “Shut Down Windows” dialog after CTRL-ALT-DEL and “Shut Down”. I then get the little dialog that says “Closing Network Connections/Saving Settings”, then it changes to “Windows is now closing down…”. These are normal I believe.

But what normally happens after that is I get the “Log In to Windows” dialog where I have to select Shutdown or Restart again or where I can Log In again. This dialog isn’t appearing - it goes straight to “It is now safe…”.

If I choose Restart it doesn’t, I get what I reported above - “It is now safe…” and no restart.

If I select Shutdown from the Start menu, I also get the “Shut Down Windows” dialog.

I tried this to confirm it is CPF.
If I disable the cmdagent service and stop cpf.exe I still get the problem when I shut down (probably because cmdagent isn’t stopped). BUT on the next boot up, with no CPF running I can shutdown and restart as normal.

So the problem is with CPF and it looks like the cmdagent service rather than cpf.exe.


I have no idea why it should either but as you can see above, I can disable CPF and the problem goes away.


Not quite, I do get the "Shut Down Windows" dialog after CTRL-ALT-DEL and "Shut Down". I then get the little dialog that says "Closing Network Connections/Saving Settings", then it changes to "Windows is now closing down...". These are normal I believe.

Actually, for W2k Pro… I don’t think it is. When you hit CTRL-ALT-DEL & select “Shut Down”, you should get a little window which says “What do you want the computer to do?” & there is a drop-down list containing the following options; Log off , Restart, Shut down & Stand by. But, yours seems to saying something different. You don’t have W2k Server do you?

No I don’t.
OK, just checked again and you’re right of course. It is as above, I was trying to do it from memory! I should know better ;D
I have re-edited my original message again :smiley: to hopefully describe what should happen and what now happens.

But to summarize, when CPF is running I don’t get the “Log On to Windows” dialog after the first “Shut Down Windows” dialog. It goes straight to “It is now safe to turn off the computer”.

This is entirely repeatable.
If I close cpf.exe I still have the problem so it suggests cmdagent is conflicting with something.

Thanks for helping me clarify this.


No, problem. I’m glad I could assist a fellow CPF user & especially since ur also a fellow W2k hero. :wink:

And I think your right, there could be something there… they did a fair amount of work on fast user switching for XP… right sort of area… wrong OS. Actually, when I was writing my post… I performed each step to make sure I had the details right & to see if I could replicate the fault. When I first pressed the Shut Down button there was a heart-stopping delay… it was long enough of a delay to make me wonder if I had just replicated your problem. I’m now left with the distinct impression that my system just scrapped passed on this one. ;D


I was wondering the same about fast user switching because it’s the “Log On to Windows” dialog that is not coming up. Instead of shutting down I tried Logging Off (I don’t usually do so because I’m the only user of this particular computer) and I get the same results.

I also get a delay sometimes when shutting down where I feel something else is about to happen and doesn’t.

egemen - any thoughts?


Hi Mark,

The delay in the shutdown process is actually normal. Starting with V2.2 Comodo built in some extra check on shut down to ensure the integrity of the firewall components.

How long is the additional delay?

Ewen :slight_smile:

Just a few seconds longer than usual, nothing special. It just made me wonder if something was happening (it is as you confirm) and whether that is interfering with not bringing up the “Log On to Windows” dialog when shutting down or restarting?


I believe the shutdown check are purely related to verifying the CPF components, in readiness for the next startup sequence.

Have you emailed this issue to, or logged a support ticket through the web site? If not, I’d do so. When they come up with a solution, can you please add it to this posting, so others can benefit.

Ewen :slight_smile:

I’ll do that Ewan, thanks for your advice.