Shockwave Flash keeps crashing in CD Ver 17.1

Hi, I had never had this problem before.

But shortly after updating to 17.1, crashes are very often.

To make it crash, simply open 3 or more tabs in CD, within each tab load a YouTube video. When you close one of the tabs, CD just freezes (most of the time) until you kill the process using task manager. Obviously this is caused by Flash.

I have tried disabling all plugins and extensions (which I haven’t installed any since the update). The problem still persists after a re-installation of CD and Flash. Currently from what I have tried, the best configuration is to enable BOTH flash plugins (incl, pepperflash) in CD, then it would crash less often.

The log in Event Viewer:

(01) General:

Faulting application name: dragon.exe, version: 17.1.0.0, time stamp: 0x4f1eaa58
Faulting module name: dragon.dll, version: 17.1.0.0, time stamp: 0x4f1ea9a9
Exception code: 0x80000003
Fault offset: 0x007886f0
Faulting process id: 0x175c
Faulting application start time: 0x01ccdc5ac134b3e4
Faulting application path: C:.…\Comodo\Dragon\dragon.exe
Faulting module path: C:.…\Comodo\Dragon\dragon.dll
Report Id: 9a096d64-4863-11e1-915c-c80aa9d05684

Details:

  • System

    • Provider

    [ Name] Application Error

    • EventID 1000

    [ Qualifiers] 0

    Level 2

    Task 100

    Keywords 0x80000000000000

    • TimeCreated

    [ SystemTime] 2012-01-26T21:20:43.000000000Z

    EventRecordID 41133

    Channel Application

    Computer Acer

    Security

  • EventData

    dragon.exe
    17.1.0.0
    4f1eaa58
    dragon.dll
    17.1.0.0
    4f1ea9a9
    80000003
    007886f0
    175c
    01ccdc5ac134b3e4
    C:.…\Comodo\Dragon\dragon.exe
    C:.…\Comodo\Dragon\dragon.dll
    9a096d64-4863-11e1-915c-c80aa9d05684


(02) General:

The program dragon.exe version 17.1.0.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: 1318
Start Time: 01ccdc448c935f7e
Termination Time: 10
Application Path: C:.…\Comodo\Dragon\dragon.exe
Report Id: ad4d354d-483a-11e1-915c-c80aa9d05684

Details:

System

  • Provider

[ Name] Application Hang

  • EventID 1002

[ Qualifiers] 0

Level 2

Task 101

Keywords 0x80000000000000

  • TimeCreated

[ SystemTime] 2012-01-26T16:28:28.000000000Z

EventRecordID 41120

Channel Application

Computer Acer

Security

  • EventData

    dragon.exe
    17.1.0.0
    1318
    01ccdc448c935f7e
    10
    C:.…\Comodo\Dragon\dragon.exe
    ad4d354d-483a-11e1-915c-c80aa9d05684
    430072006F00730073002D00700072006F00630065007300730000000000


Binary data:

In Words

0000: 00720043 0073006F 002D0073 00720070
0008: 0063006F 00730065 00000073 0000

In Bytes

0000: 43 00 72 00 6F 00 73 00 C.r.o.s.
0008: 73 00 2D 00 70 00 72 00 s.-.p.r.
0010: 6F 00 63 00 65 00 73 00 o.c.e.s.
0018: 73 00 00 00 00 00 s…


Thanks.

Since we aren’t supposed to start new threads for the same problem.

Just wanted to chime in, I’m running CD v17.1 on 64 bit Windows 7.
Using the latest stable version of flash.

If I try doing more then one thing that requires flash, CD ends up going into a not responding state. If I choose to wait instead of end task, CD ends up requesting the Flash plugin be disabled.

I have not experienced this problem on other chromium forks.

Also, I found that as soon as I close CD, the pepperflash plugin would be automatically disabled. So every time when I open CD, I must go to about:plugins and enable pepperflash. Otherwise it would crash if I watch YouTube videos.

I’ve noticed this too. Pepper flash will not stay enabled at all. Also, Dragon only crashes when I close a Youtube video that’s playing. If I pause the video before closing the tab, everything’s fine.

Scratch that, I just had a crash without anything playing.

Also I have just found out that, when you have just done a fresh install of CD, it does NOT have pepperflash. However, after hours of using the browser, pepperflash appears to have automatically installed.

Any idea why this is happening? In previous versions of CD, there was not pepperflash.

PS

I noticed that this only happens with YouTube. It does not occur when you visit other sites that use flash to play videos (such as tudou.com). Does it have anything to do with YouTube? ??? ???

As a side note, this exact situation also occurs when using Google Chrome 16.0.912.77.

Does anyone know of any way to enable pepperflash by default? ???

Hello,

Please try the following steps:

  1. Enable Flash player plugin
  2. Open “dragon:\flags” in a tab and enable “GPU composinting on all pages”
  3. Restart Comodo Dragon

Thank you.

This seemed to fix the flash problem for me, so far. But has added an “oddity” to many of the pcs I set this on. Where tabs don’t draw in until you switch to them, and sometimes you have to wait a bit (seconds though, not minutes). Other times they don’t draw in until you refresh whatever should be on that tab.

Thanks for the reply. I am still testing it. For the past 2 days I think at least most of the time the problem seems to have gone by itself before I read this reply, ie it did not crash even when I sometimes forgot to enable pepperflash.

Thanks.

I got this issue too.
CD 17.1 (Portable) crashes when there is a flash object on the page.
It crashed on YouTube, Ted Talk and even my yellow pages local site (ridden with flash nonsense).

I think I have the same problem. I dont really know it for sure, because for me Dragon just keeps crashing randomly. Sometimes when i play flash videos it does not crash, other times when i dont even touch it, just runs in the backgorund it suddenly crashes. Its hard to tell whats the cause of this, because almost every page has some flash content, at least some banners, and as i said the crash is not triggered by some “input”, or at least not by me. I can imagine tho, that its caused by a malware, some sort of exploit, but thats just a possibility, it can also be a bug.

Hi Blendea George-Silviu,

This does not resolve the issue for me.

Hello,

The issue is currently under investigation.

Thank you for your support and feedback.

I was having a problem similar to this, it also happened elsewhere but it seemed to happen more on YouTube. I installed the latest flash release 11.2 r202, and that didn’t fix it.
It turned out to be a bad extension. Every time it tried to update it would crash the browser and even when it was disabled it would still crash it, so i uninstalled all my extensions and reinstalled the latest versions of them and i haven’t had any trouble.

That sounds plausible, I have the same issue.
I can’t update AdBlock I’m currently running version 2.5.12. latest is 2.5.16.

I’ll see if it stays alive after disabling this add-on.

Can you please check if this issue reproduces with out latest beta ver 17.2:
http://download.comodo.com/dragon/beta/DragonSetup.exe

Are you referring to the crash while checking for add-on updates?

I can update the add-on in 17.2b without it crashing dragon :-TU
Will now see if the ‘flash crash’ is also gone.

No, i’m refering to Shockware Flash that crashed CD.

Well I haven’t had the issue again, but I still think it might be related with the add-on crash, how often does it check in the background for updates?