Shields Up reports Port 0 as closed

I recently installed Comodo Firewall and tested it out with Shields Up ( Port 0 was reported to be “Closed.” All of the other ports were reported as “Stealth.” My previous firewall, Zonealarm always reported all ports to be “Stealth.”

Is there any setting I can change, or is this an inherent weakness in Commodo?

Welcome to the zoo–I mean forum, Zookeeper :smiley:

Your issue is just like this one, only yours is port 0 instead of port 1 (:LGH).

I searched the info on Port 1. Nothing there seems applicable to my problem with Port 0.

My router, a Netgear WGR614, doesn’t have any way that I can change settings for Port 0.

I don’t understand why I’m suddenly having this problem, in that all ports, including Port 0, were reported to be Stealth, when using ZoneAlarm.

I’m not sure. But if you have both a router and CFP and it’s closed, at least you know you’re protected. According to Shields Up!! itself:

"Port Zero" does not officially exist. It is defined as an invalid port number. But valid Internet packets can be formed and sent "over the wire" to and from "port 0" just as with any other ports.

I just discovered something very interesting. When I did the Shields Up test that showed that Port 0 was Closed, I had Outlook Express running in the background. When I closed Outlook Express, Port 0 was reported as Stealth.

When I closed the Firewall completely (& only used the firewall capabilities of my router), Port 0 was reported as Open when Outlook Express was running in the background. It was reported as Stealth when Outlook Express was closed. My router doesn’t permit me to make any modifications to the way it handles Port 0 (modifications are permitted for all other ports).

Outlook Express does not use Port 0. Why would it be doing anything to Port 0? I tried blocking Port 0 completely for Outlook Express from inside Comodo, but this didn’t affect any of the results. I’m more confused than ever.

Hmm, sounds like a MS conspiracy theory in action, to me… (:KWL)


Isn’t that a convenient explanation :P.

Zookeep, what happens if you created a network rule to block port 0 (and put it at the very top)?

How would I go about creating a network rule to block port 0?

How about this test? In Network Monitor create a rule. When finished move it all the way up to slot # zero:
Permission: Block
Protocol: IP
Direction: In
Source IP: Any
Destination IP: Any
Source Port: Any
Destination Port: 0

If the site still doesn’t show it as being stealth then it’s obvious that the site is scanning your router, not your computer. Although not necessary, you might want to clear your browser cache before re-testing. If still unconvinced, try a different scanning site like Advanced Port Scanner | PCFlank or Home -

Sounds like the issue i had, read here see if it helps:,6198.0.html

I tried it. Port 0 is still being reported as closed.

I tried Drob’s suggestion of blocking outgoing - still no help.

I went a little further and in application monitor, I blocked all access, both incoming & outgoing, to port 0. That didn’t work either.

I don’t think that it’s a router problem since closing Outlook Express makes port 0 stealth. I was wondering if someone else could try to duplicate my problem - Run Outlook Express in the background while testing your ports with Shields Up.

Thanks to all who have tried to help.

Network Monitor rules have the final decision regardless of what you have in the Application Monitor rules.

What about the other scanning sites?

I haven’t been any able to find any other sites that check port 0. Except for GRC, all of the sites I found start with port 1.