Shared Space desktop shortcut refuses to stay deleted

A. THE BUG/ISSUE (Varies from issue to issue)
Shared Space desktop shortcut refuses to stay deleted
Can you reproduce the problem & if so how reliably?:
Quite easily, comodo keeps placing the desktop shortcut back on the desktop
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: delete shortcut
2: open comodo window and the shortcut shows back up
One or two sentences explaining what actually happened:
There is no option to tell comodo to not place shortcuts on desktop. And sandbox is disabled and shared space shortcut is not wanted.
One or two sentences explaining what you expected to happen:
I expected the shortcut to stay deleted.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
I tried unchecking both shared space’s “do not virtualize” options, hoping that it would stop it.

Exact CIS version & configuration: Auto-sandbox is disabled
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
D+/HIPS enabled safe mode, Autosandbox disabled, Firewall/AV enabled safe mode/stateful
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5 or CIS6?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 7 SP1 64 bit, UAC default, admin
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Microsoft Security Essentials b=ccleaner

[attachment deleted by admin]

Please attach a diagnostics report.

Thank you.

Took me a while to find the report generator. It reported nothing wrong. It’s attached to the original message.

Please try a clean reinstallation using this guide. Does the issue persist?

Also, is the mentioned folder removed upon uninstallation?

It did not appear to remove the folder during uninstall, however I manually deleted it.

The fresh reinstall seems to stop the behavior.

In that case, I will move this report to “Resolved/Outdated Issues” section.

Thank you.