Shared folders don't work anymore

After running COMODO registry cleaner, my shared folders are not accessible over the network anymore. Even after restoring the registry from the registry cleaner back-up in, they still don’t work.

My sysadmin went through all the sharing and security settings on my computer and he couldn’t make it work either (and he’s pretty good).

also tried creating new shares but they didn’t work either.

Any advice will be most welcome.

Using Win XP Pro (SP2)


System cleaner removed the folowing from the registry


If you know what you are doing just re-create the IRPStackSize entry and it will work again.

Thanks for the quick reply. Unfortunately your suggestion didn’t work.

I checked another computer on our network for which sharing is working fine and it doesn’t have that key either.

I should point out that that we are on a domain and not peer to peer.

Any other ideas?

Got it working now. Had to put the IRPStackSize registry key in CurrentControlSet and then it worked.

A couple of questions:

  1. How is it that sharing works fine on other computers on the same network even if they don’t have this registry key (I searched their registry and didn’t find the key anywhere)?

  2. Why didn’t COMODO’s registry backup restore whatever setting it had changed?

I am curious to understand what is really happening so I can avoid similar problems when using COMODO System Cleaner in the future.