Shareaza - inbound policy violation? [Resolved]

Hello, can someone please help me configure Comodo to allow downloads throo p2p Shareaza. The firewall allows the program to connect to all the networks, but download sources are all limited do 20 sources per file. The “Limit connections by this application” option is NOT checked. When i close Comodo, sources jump to 600-800 and DL speed is blazing fast. With Comodo and 20 sources, downloads are almost non existent, or very low speed. I have set the rulez to allow all activities by that application, to allow invisible connections and to skip advanced security checks, and still nothing! I have to close Comodo when i download with Shareaza, and thats almost 100% of the time. Also when i closed Comodo, my Nod32 detects trojans and viruses all the time, deletes all of them, but i had to run bitdefender online scan on the last virus that nod couldn’t kill.
Basicly, i really need Comodo and i really need your help in configuring it, im in a loss.
If this is any help, the logs say Shareaza - Inbound policy violation, connection terminated on thousands of Ip adresses, those are probably download sources that are terminated. Why does that happen?

Tnx in advance,

[Added resolved to title as per topic starter’s indication]


Go to Network monitor (security/network monitor).
Right click on your block rule and add/add before.
Do these settings.

Action : Allow
Protocol : TCP or UDP
Direction : In/Out
Source IP : Any
Destination IP : Any (or zone if you have one)
Source Port : Any
Destination Port : A single port : enter Shareaza port

I don’t have Shareaza so I don’t know how many ports it requires for incoming connections, but if it’s anything similar to uTorrent, your rule is not entirely correct. It’s fine for incoming, but not outgoing connections because it’s currently set to only connect out to outsiders that use that single port. I’m surprised your speeds are as fast as you have experienced.

However, if you have the default TCP/UDP Out allowed rule at the top, then you really should change the rule you posted to:

In (only, no Out!)
Any (or zone, whichever applies)
Single Incoming Port

You won’t notice any change, but it’s more efficient because there won’t be any overlaps.

i have tried that already, but when i set
Protocol : TCP or UDP
Direction : In only

nuthing happens. I mean, my problem is still there unless i set in and out. Know what i mean? (:SAD)

Please post a screenshot of your rules. Maybe you modified the default Network rules or there’s something in your Application rules that’s preventing something.