Severe system slowdown and weird window glitch after install...

I just installed CIS earlier, after removing Avast, switching off windows firewall etc, several reboots and everything appeared to be ok at first. But I have severe lag now with my system, for instance, if I move a shortcut on my desktop a bit, I’m getting serious lag, I’d say 5fps, when I do so.
Also, in drop down menus/side menus, the options are now invisible, I just get a shadow around where the box should be. For instance, going to shutdown and clicking on the little arrow to find the restart option, its just a shadow outline. Also it happens even in comodo, for instance going to advanced settings and the firewall, to where it says it is enabled, and there’s a drop down where its set to safe mode, again all I see is a shadow border of where the box should be.
I followed another topic that said it could be due to remnants of Avast, I downloaded the tool to remove it fully and I have checked my computer since for anything relating to avast and have found nothing.
I have also tried disabling the anti virus and firewall separately to see if they are causing the lag/ invisible window problem. Its still there though.
I’ve been checking in task manager to see if anything in particular is taking up the cpu, nothing is out of the ordinary, except for explorer.exe taking 50 when trying to move a shortcut around on the desktop.

I have Windows 7 Ultimate, Service Pack 1, AMD Athlon II X2 250 Processor 3Ghz, 8gb ram, 64 bit. AMD Radeon HD 6670.

EDIT I have followed the topic for doing a clean install here: Comodo Forum
Once comodo was out of my system everything was running as normal so it is definitely causing the problems. But after running the uninstaller for cis, it has managed to wipe all my drivers… And at the moment I am struggling to get any of them back so now there is a new major problem.
Also, once I installed cis again, I kept checking the performance on my desktop and it seemed to be going fine and the window glitch wasnt there either. This was while it was downloading the new signatures. It asked for a reboot and as soon as the computer was started up again, everything has gone slow again AND the window glitch is back. Still no drivers… For most of my drivers in device manager I have this message: The driver for this device might be corrupted, or your system may be running low on memory or other resources. (Code 3) And yes I did run the uninstaller in safe mode.
This is URGENT, need the computer running properly again for important assignments, if it can’t be solv ed soon I will have to resort to a different software all together.

Judging by the Code 3 message something is using a lot of resources.

Please make sure the following Advanced HIPS settings are disabled:

  • Enable adaptive mode under low system resources Enable adaptive mode under low system resources
  • Block all unknown requests if the application is closed
  • Enable enhanced protection mode

Let us know if disabling them makes a difference or not.

Did you have other security programs in the past other than Avast? If so run the removal tools for those programs to create a level playing field.

Hey there.

No I haven’t had any other security programs other than Avast.
HIPS was disabled by default.

Over the last few days a couple of my friends together managed to solve some of the problems. First off, it was defense + that was causing the lag on the desktop. As soon as defense+/behaviour blocker was switched off, it stopped lagging and also the drop down box glitches stopped happening. It turns out that it had blocked all of my drivers, classing them as suspicious and was even blocking parts of explorer, which is what was causing the lag. I was told that HIPS should not have started up in safe mode automatically.
Basically comodo has labelled half of the things needed to run my computer as dangerous and isolated them in the sandbox.

(Also, I found a topic here on the forums where someone was also having the window menu glitch that I was having, and he has screenshots too: https://forums.comodo.com/install-setup-configuration-help-cis/nothing-in-the-drop-down-menu-t92779.0.html There’s no solution there, but the way to fix it is switch off behaviour blocker all together, if anyone in the future gets the problem)

I was forced to uninstall comodo and try to reinstall my drivers. (By the way, it had even blocked the new motherboard drivers I had downloaded from the official site) Something was still preventing me from updating the drivers. There was nothing wrong with the system resources, so that was not the cause of the code 3 error. The cause was comodo blocking some very important processes and files.
Even after removing comodo fully, something important had still been labelled as dangerous and would still not allow me to fix the drivers and missing dvd drive problem. Removing comodo should really have fixed the false reports on everything, but apparently it broke something permanently.
We were trying for hours on end to at least get my dvd drive working again so I could perhaps run the motherboard driver cd to see if that would fix the problem, but to no avail.

I had been following official microsoft advice on how to fix corrupted drivers, and not one solution worked.

Here is a screenshot of all the drivers it had broke: http://i.imgur.com/cdsmqXW.png
And also a screenshot showing just some of the things that defence+ was messing around with http://i.imgur.com/AoOfvWU.png
And a screenshot where even microsoft fix it couldn’t solve any of the problems created: http://i.imgur.com/54UcUek.png

This has all been fixed now however by doing a system restore from quite a while back. I have been forced to return to Avast now as my experience with comodo has been terrible and I do not trust the program at all after what has happened.

For some added information, here is the product and database of that comodo version.
Product Version: 6.0.264710.2708
Database Version: 15761

Thank you for your extensive report. I am glad you managed to fix it. Sometimes system restore is true friend.

After the fact of system restore to solve the problem it is hard to tell what went wrong. So I will give a general outline of angles I would have taken to try to understand what is happening. First of all it looks like the Trusted Software Vendor list may have gotten corrupted missing vendors.

The D+ logs I would have asked for. I see that various executables belonging to drivers were not being run as trusted. That could also indicate to a problem with the Trusted Software Vendor list.

I would also consider the possibility that unneeded files were on the unrecognised files list.

Sorry not being able to be more conclusive…