Severe Slow Down of Shutting down PC [Resolved]

Hey Guys,

Long time user of CPF and I love it! Anyway whenever I go to shut down my Windows XP Pro Service Pack 2 Machine, it takes a long time. About 3-4 minutes!! So I tried shutting it down without CPF running. I quit it in the tray and the cmdagent.exe. System shutdown in 20 seconds! Any idea whats causing it? BTW I’m running the 2.4 latest release. CPU is a AMD 2800+


All issues are resolved, see below…

I also had issues with slow shutdowns. I started using the User Profile Hive Clean utility available free from Microsoft. I have attached a link below. When I installed this on my XP Pro pc the shutdown went from taking over 1 minute to taking about 12 seconds.


Thanks Anderow. That tool helped a lot. Now it only takes about 20 seconds to shut down. I do have another gripe though. When I start up my computer it will start normally and then when it gets into Windows, CFP will block my LAN Icon from showing near the clock. When it does this any app that uses the net can’t. AVG is constantly saying that I’m not connected to the net. I know that this is a nice feature but is there anyway to disable this behaviour?

Wow did that tool ever work! I just did my second shutdown after running it and this time my computer was off in 10 seconds. Now if only I could solve the start-up problem…

You might check under Security/Advanced/Advanced Attack Detection, make sure the box “Block all outgoing connections while booting” isn’t checked.

You may also have restrictions (based on your application and/or network rules configuration) which prevent the system from immediately connecting to the DNS and DHCP servers for your IP address, so you can gain internet access.


I had a similar problem once on a pc which had a HP all-in-one printer installed. Once I prevented the various files associated with this printer from starting at boot up everything went back to normal. Incidentally, as the silly HP software had no options to disable startup files I used Spybot to prevent the start up files - doesn’t work for everything but it stopped these HP files from starting. Everything worked ok after this even with “Block all outgoing connections while booting” checked.
Perhaps Acid0057 has a similar problem, maybe not a printer but some other software causing problems at start-up.


Could certainly be true, Anderow. A handy-dandy startup manager might do the trick, too. There’s some in our collection of free proggies…,1731.0.html see the Utilities section.


I did exactly as you said Little Mac and it worked. Along with me changing the LAN Icon to not appear on the system tray. Also CFP Was stopping my APC Shutdown Service from starting too and unchecking the “Block all outgoing connections while booting” fixed that too.

Great! Then I’ll mark this one as “Resolved” and close it. If you need it reopened, just PM a Moderator (please include a link) and we’ll be glad to do so.