Several small things with 3.0.12 x32 and 3.0.13 x32[BUGREPORT]

First of all great job with V3 it’s definitely a very impressive release. Last time I took a look was around 2.3 time frame and went back to Sunbelt Firewall. Now I am taking another look and so far this one is definitely a lot more impressive. Installation of 3.0.12 went fine and I got it setup in advanced and the most paranoid mode with maximum alerts.

A couple of things though:

  1. I got an update notification (even though I went and disabled auto updating) which showed a new icon in the tray and when I clicked I got a HTMLHelp window which I couldn’t close because it would show up again and again. After poking around I figured out that it was covering the updater application. But then I couldn’t click apply for some reason. Somehow I managed to kill the updater and do a manual update which seemed to have worked fine.
  2. I really love the “Network Control Rule” dialog. Can you please please please add some button to the alert dialog to open “Network Control Rule” dialog to create new rules? Something like “advanced”?
  3. I noticed that there’s something called “Installation Mode” in defense+, but looking through the menu that I get from the tray icon there’s nothing that shows it.
  4. This one is really minor. There’s no help or about menu from the tray icon.
  5. In terms of the new GUI it’s very impressive and has a lot of options, some of which take a bit of time to figure out and find where to change things. Like one example is editing application rules and having that dialog open and starting another application and accepting and saving some new rules doesn’t refresh or update the editing application rules window. After closing and re-opening it seems to be updated with the latest rules. Also another usability option is that if I am editing “Network Control Rule” and I need to see or edit the ports for POP3 I need to go through a bunch of menus and screens to find that edit dialog option.
  6. Is there a way to create or update the default application classes and port sets? I know I saw some already and I am slowly adding my own sets or updating existing. I guess i can contribute back some sets to cover application(s) or port sets. One option was to add POP3S (995) to the list of POP3/SMTP port set.

Thank you for such a great product, patiently waiting for more bug fixes and cool new things.

Gena01

I would like to add my experience with the first item on the list, I had to resolve the thing by logging out of the profile then forcing an update when I logged back in.

So I played some more with Comodo yesterday trying to see if it’s stable enough for most of my day to day things. And unfortunately it’s not. Allow me to explain. I have it setup as explained above in the first post to be in advanced/power/paranoid mode.

Here are some things that I ran into (some of which are rather critical):

  1. There’s no way to set Comodo disabled or to somehow tell it to Allow ALL traffic. I tried closing the firewall from the tray and tried to launch apps which don’t have rules setup in Comodo yet. They failed to connect.
  2. I tried selecting “Firewall Security Level” to Disabled, but I was still getting alerts to allow each connection to come through.
  3. I tend to do some work from home so we use Juniper Netscreen Remote (VPN client) which I tried to use at home. VPN seemed to work fine until I disconnected. Somehow after I disconnected the VPN interface wasn’t shutdown properly and my internet would stop working at ALL. I tried to uninstall and reinstall the VPN client and I am still getting the same issue. I know that when I had Sunbelt firewall this was never a problem, so this is something new and I am suspicious that there’s a bug somewhere in Comodo.
  4. Is there a way to Allow ALL apps access to DNS? I tried to create a “Global Rule” but somehow I was still getting alerts on a per app basis asking permission to connect or send UDP packets to port 53.