Setup for Logitech Vid(Webcam App)

I’m trying to get Logitech Vid to work . with Comodo disabled it works fine. When Comodo is active it doesn’t connect. The ports it uses are udp 9000-9005. I’ve tried everything I know but I can’t solve the problem. Their tech Support said that all I needed to do was allow the VID.exe app and it should work but it doesn’t. Would appreciate any assistance. Thanks

Have you tried adding this particular file to your safe list by going to Defense+ / My Own Safe Files.

Then manually add the file to the safe list.

Yes I have, with no results

If this is any help, Attached is a Screen Capture of Active connections when Comodo is disabled and Vid is connected and working.

[attachment deleted by admin]

Can you show a screenshot of your Global Rules? They are under Firewall → Advanced → Network Security Policy.

Here you go, thanks

[attachment deleted by admin]

I just looked up the app and it is meant for video calling. It more than likely needs open ports to function properly.

Read the following tutorial I made. Substitute the port numbers and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

Next step for now is to give the Vid.exe a Trusted policy under Application Rules (Firewall → Advanced → Network Security Policy).

Did all and no change. Only deviation was instead of one port I defined a group (9000-9005) and used the group in destination port setting.

Can you post a screenshot of the Firewall logs? They are under Firewall → Common Tasks → View Firewall Events.

There are no entries in log relating to Vid.exe. I have attached shots of the active connections under different conditions. 1.jpg is firewall active and vid running, 2.jpg is comodo disabled and vid running and 3.jpg is comodo disabled and connected to a friend(all working properly). Thanks

[attachment deleted by admin]

Can you show me screenshots of

  • Application Rules of the Firewall (Firewall -->Advanced → Network Security Policy)
  • Computer Security Policy (Defense ±-> Advanced)
  • D+ logs (Defense + → Common Tasks -->View Defense + Events)

There were no entries in D+ logs and the others are attached, one each in Net Security and Comp Security policy.

[attachment deleted by admin]


I was having the same problem and found this thread looking for a solution. I think I have found it.

Open Comodo | Firewall tab | Firewall Behavior Settings | Advanced | uncheck “Block Fragmented IP datagrams”

I don’t know why; I just reached the point where I thought I’d start trying everything!

Hello. ’ pklentz’ solution worked for me as well. What I need to know is does ‘unchecking this’ compromise the ability of the firewall in anyway.