Settings in router

I’ve set the Comodo SecureDNS IP addresses in our router (a Zyxel) and, in the end, it seems they’re working, as I get the SecureDNS help screen if I enter an invalid URL.

But, on both Windows and Mac, the original DNS IP addresses from our ISP are still shown - neither the Properties for the connection under Windows, nor the Network System Preferences (or System Profiler) on Mac, can be made to show the Comodo SecureDNS addresses. I tried renewing the DHCP lease, turning the (wireless) connections on and off, and rebooting the router and the computers, but still the original ISP DNS addresses continue to show.

Anyone know WHY this is the case?

I also Googled to try to find a way to confirm the IP address that’s actually being used, but it seems that this is not possible? Is that right?

Have you tried next command?

ipconfig /flushdns

Also, make sure TCP/IP Properties DNS option is set to “Obtain DNS server address automatically”.

No, I hadn’t tried that command ('cos I didn’t know it!), but I have now and it ran successfully. I also checked the TCP/IP properties and yes, “Obtain DNS server address automatically” is set on. But, flushing the dns hasn’t changed anything. Even dropping the connection and re-connecting hasn’t altered the DNS addresses displayed in the connection details - the ISP DNS addresses are still showing there. Seems that ‘somewhere’ they’re still being ‘remembered’…

Any further thoughts?

You can try an opposite approach.
Enter DNS IP addresses in TCP/IP Properties of LAN card and use default (auto) addresses in router settings.

Well, yeah, I’d sort of worked out that I could do that, but then, setting them in the router IS working and saves having to manually configure all of our computers individually (as the Comodo instructions suggest). So, my query was just trying to get a better understanding of why the computers (Windows and Mac) don’t then show the actual DNS addresses that are configured.

I always get somewhat curious when things work, but not exactly as they should!

Thanks for the responses though… :slight_smile: