SESSION5_INITIALIZATION_FAILED [FIXED]

I have both PATA and SATA Drives. I enabled SATA ACHI months after I installed XP following step to step faqs on internet. I have no HD listed in MS Safe hardware removal utility.

My MB has three/four contollers. An Intel ICH6 with 2 PATA CDROM/1 SATA HD, An additional PATA Controller with 2 HD and an additional SATA controller I disabled (In case anyone wonder I was forced to buy this MB because I could not afford to wait when my previous faulty ATX power supply destroyed my previous board. 12 SATA/6 PATA are too much I guess this MB need an externnal case only to host SATA drives :o )

I Uninstalled CFP and CMF and I got no BSODs. The event viewer entries about chkdsk are the same I got when CFP was installed
Installing CFP firewall only whithout leak protection don’t workaround these Stop f4 BSODs anyway I’ll try this again to confirm.

Ther is only one thing I would like to try but I don’t if there is a way to do this (O guess I should read more MS technet whitepapers).
I would like to run a chkdsk on my system/boot sata drive and then remove the command that triggers chkdsk on startup.
Just wondering if the issue happens before reboot in order to tun checkdisk.

:SMLR
LOL, same here, I’ve upgraded about 5 months ago because smoke was coming out from the pwrsource.

Off course I’ve done the same this morning, uninstalled CFP – but saved settings -by bad - in Firewall folder, being used with updates – you can guess the folder was empty after uninstall – so now I’m writing zones, DNS’s and rules.
Sorry I cannot tell you anything about triggering chkdsk – never needed.
I almost got a crash.dmp, but it was empty :frowning:

  • anyway even if chkdsk is stopped before execution “press any key…” it triggers the crash.

Yep I found out that saving money on my PSU backfired on me so now I got a Megalomaniac PSU. Since I need only 1/3th of its wattage it should last at least 10 years (I hope)

Good to know that is another hint. I never thought of that my bad :-[

You confirmed that the actual chkdsk process is not involved.

I only found out that HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
stores the chkdsk command (eg autocheck autochk /p ??\C:) If I remove that the issue disappear.

New 3.0.18 is out I’ll test it asap.

with CFP fireawall only without leak protection (new installer wizard option) I got a stop f4 bsod only after I attempted a second logoff to welcome screen.

I just tested 3.0.18 Stop F4 bsod issue still here I can trigger it using logoff to welcome screen.

CFP 3018.309 - clean install
Hi gibran, thanks for the link and feedback.
Just when I’ve opened a text editor to announce that issue was fixed – starting Ooffice Writer caused: reboot :frowning:
Something has changed – crash is not so obvious here anymore, but I still can’t run applications. I got this in apps. events:
[i]A critical system process, C:\WINDOWS\system32\lsass.exe, failed with status code c0000006. The machine must now be restarted.

For more information, see Help and Support Center at http://go.mi
[/i]
Anyway, I have the most checked disks ever. (:KWL) You can safely add the 3.0.18. ver. change to the topic name, on my account.
I’ve missed the 5 seconds – so I had to wait for a chkdsk to complete.
How can I trust now to run a registry defrag or other installs/processes that take place before boot?
Next issue is to see: “All your base are belong to us” … sorry for the joke – but I really want my boot process left alone; also I use Comodo for too long now to wait not for a fix. - sorry for the engrish.

I just tried the new version and it still gives me BSOD

In order to fix this issue a minidump is of utmost importance.

Please read BSODs: Please add your minidump files here
in order to provide all info needed to address this issue

I’m having that problem too!

First i thought that it was a consequence of using Spinrite because i had suspicions of bad blocks on my HDD (system drive) and after using it (also coincided with me doing a chkdsk /F at boot time before trying Spinrite) it got unbootable.
Anyway while trying to find a reason for the problem in google, i found this thread and did some tests. What is tested is… with comodo installed and schedueling boottime scandisk (chkdsk c: /F) and system gets unbootable and after restoring a backup image of the system drive, if i unninstall comodo and try chkdsk again at boot time, i don’t get any problem.

Let me just say that this is a really HUGE bug since at least for me my system was UNBOOTABLE, in “normal” boot i get the error STOP 0x71 like in the topic and if i tried “Last Working Config” i’d get STOP 0x7B so it’s a no no situation. My luck is that i have periodic backups of my HDD made by Acronis TruImage otherwise i would be really ■■■■■■■.
Since my HDD becomes unbootable there is no way for me to get any minidumps if there are any. (:AGY)

There must be something that Comodo does at boot time that screws up the boot files/registry or the filesystem and it needs fixing.
The versions i noticed this are the latest (3.18 and 3.17) but i didn’t do chkdsk at boot time for a while so it might have affected previous versions too.

Of course i will help you as much as i can, but in the mean time i think i’m not going to use Comodo Firewall because i don’t want to risk my luck and lose any important data i can’t recover.

Using Windows XP SP2 lastest patches, CPU P4 2.8C, 1.5GB RAM.
The system disk is a Hitachi 250GB with 3 partitions it’s an IDE disk.

Please Help (:WAV)

I had a bad feeling that I will rain down with confirmations (:NRD)

I also find alot of issues from this forum when googlng – not sure if it’s good or bad. :stuck_out_tongue:

it IS from Comodo, because I’ve seen one instance of the GUI dialog for less than one sec.– but it disappeared, with reboot.
Don’t play with it if you don’t have a backup – I don’t think 3.015 was affected by this, should be something new – 3.016 and newer.
I haven’t lost any data – but there were some experiments back in 3.012 or so, maybe latest beta stages, I cannot remember – that resembled to this behavior.
If you’re in control of your PC, and not the other way around, I recommend – but it’s YOUR choice - to backup your sensitive data on some USB drive – dont’ give up Comodo FW.
Thanks for the feedback. Gabi

I’m not giving up Comodo, just not using it until this issue is fixed. Hope it is fixed fast! :■■■■

I had some spare time, so I did more digging into the matter.
Event Type: Information
Event Source: Winlogon
Event Category: None
Event ID: 1002
Date: 2/21/2008
Time: 6:35:50 PM
User: N/A
Computer:
Description: The shell stopped unexpectedly and Explorer.exe was restarted…

Event Type: Error
Event Source: Winlogon
Event Category: None
Event ID: 1015
Date: 2/21/2008
Time: 6:35:55 PM
User: N/A
Computer:
Description: A critical system process, C:\WINDOWS\system32\lsass.exe, failed with status code c0000006. The machine must now be restarted…

Then comes the beauty: a blue screen, but not the usual BSOD; just in the top left corner:
“STOP: c0000021a Unknown Hard Error
Unknown Hard Error”

Couldn’t get any debug/dump.
IMHO this is getting too serious, and needs to be addressed ASAP

googlng for events:
Event ID: 1015 (can aplly only to WIN2003)
As per Microsoft: “The system default profile appears when nobody is logged on. This event record indicates that the changes that the user made to the default profile were not saved to the local system. The user will have to use the system default profile at the next logon session”.
As per Microsoft: “This problem may occur when an inheritable Deny access control entry (ACE) is applied to an organizational unit (OU) that inherits only to user objects but applies to all properties. The access violation occurs when a principal that this Deny ACE applies to queries users in the OU”.

Using StartupList from merijn.org:
When scheduling a chckdsk, changes are stored in:
Wininit.ini (- I don’t have this one -) or/and
HKLM\System\CurrentControlSet\Control\Session Manager
This Computer\On-reboot actions\BootExecute = autocheck autochk /r ??\C:
Removing Wininit.ini and the registry key from D+ protected files/ keys didn’t helped.

That’s about all so far.

It seems this issue can cause different bsod but most users get stop 71 bsods.

ALL poster please confirm these points:

  1. As gaby pointed out this issue can reproduced even if chkdsk is skipped at bootup.
  2. As goodbrazer pointed out this issue seem to not affect machines where boot and system partitions are different (eg windows is installed on a 2nd HD on a dualboot system)
  3. This issue can reproduced even if Defense+ is disabled (there are 3 way to disable D+: setting D+ slider to disable, checking “Deactivate D+ permanently”, installing CFP firewall only WHITOUT protection option)
  4. So far no Vista user reported this issue
  5. Os is istalled on a sata drive

NOTE: on my system I get a stop f4 bsod and I’m able to get a crashdump. To ensure that my system is stable I do few logoff/logon. This cause a BSOD when I test this issue.

I can confirm all four of them

EDIT: I spared to many words. I’ll list them in a proper way.

  1. Yes
  2. My system and boot partition are the same.
  3. I can trigged this issue regardless if D+ is enabled disabled (although if D+ is enable no action is needed to trigger a BSOD)
  4. Confirmed on windows xp (stop f4)
  5. yes

In order to confirm that your system is properly set to create crash dumps please look at BSODs: Please add your minidump files here

1.Yes.
2.Not sure – I have another PC – that is not affected, and has both boot and sys on C:
https://forums.comodo.com/bug_reports/session5initializationfailed-t19438.0.html;msg136559#msg136559
3. EDIT - Installed FW without D+, only Anti-Leak prot. No influence.
D+ settings are of no importance – I don’t think a driver (cmdguard.sys or cmdhlp.sys) is able to read settings – for that, a *.DLL would be needed.
4.No Vista here, sorry – not to mention that it’s about a monthly average salary in this part of the world O0 , I’m not sure I won’t rather migrate towards Linux.

I still think it’s a hardware related issue; an incompatibility with another boot loaded driver.

  1. Yes
  2. I don’t Know
  3. My Defense+ is disabled (not deactivated). To say the truth i chose during installation to not use defense+, but nevertheless i had to disable it manually.
  4. I don’t Know
  5. WinXp is installed on a sata drive (NTFS)

Bye

  1. Don’t remember if it does.
  2. Using same disk as boot and system (no dualboot)
  3. Only tested with Defense+ active
  4. Using XP Pro Sp2
  5. No. I’m using IDE HDD as boot.

Btw, i did not have ANY BSOD from Comodo (or any other app) except the 0x71 and 0x7B related to using chkdsk at boot time.

Again, my problem occurs after successfully completing the boot-time chkdsk (chkdsk c: /F) after it “makes corrections to the filesystem” it reboots again just like it would but then when loading windows XP there comes 0x71 BSOD right at the beginning of the OS loading with the progress bar. If i try and pick F8 option “Last Good Settings” it starts to load and like before i get a BSOD but this time it is 0x7B. Only way to “fix” this is restoring a backup image of my system partition.
If i uninstall Comodo firewall and try the boot-time chkdsk it does what it needs to do “make corrections” and windows boots normally no problems. (:TNG)

1- I didn’t try. I’m afraid to do checkdisk at boot.
2- Mine are on the same partition.
3- Mine is enabled.
4- I have XP.
5- Wrong, my HDD is IDE.

I just experienced this BSOD …71… error/behavior a coupla hours or so ago after scheduling chkdsk /f on my XP (NTFS) dual-boot system partition (D). My boot partition is C (DOS/FAT32). While I’ve seen BSODs on this computer (among many others) I believe this is the first time I’ve seen this particular one. I ran CPF 2 for this setup for quite some time, I’d never had this problem until I installed CFP 3 - which I believe I iinstalled last week. This was the first time I scheduled chkdsk /f since that install.

  1. Yes. After the BSOD on automatic startup after Chkdsk /f, even if chkdsk hasn’t been rescheduled, the BSOD occurs again.

  2. Iffy. It DOES occur on machines where boot and system partitions are different - ON THE SAME PHYSICAL DRIVE. I do not know if it occurs “where windows is installed on a 2nd HD on a dualboot system.” NOTE: I just restored (via cloning) my system (D) partition - WITHOUT restoring my BOOT partition and got a perfect boot. Thus I suspect it doesn’t matter whether your system and boot partitions are the same partition, and suspect it would happen wherever your system partition resides.

  3. Re Defense+ on/off: I don’t know, as I don’t have time to try this, since the only way I’ve found to recover is to boot to another cloned physical hard drive and then clone it back, since it won’t even boot in safe mode. (It get’s into a reboot loop.) I would have to do the clone/trial several more times to confirm.

  4. I have XP Pro (w/ all updates), so don’t know about a Vista issue.

  5. Yes, the OS is installed on SATA drive (WD5000AAKS).

FWIW, all of my apps and hardware drivers are up-to-date. (I use Secunia and other apps to constantly check. And, yes, I know it’s compulsive.)

I really like CFP 3 (as I did 2), but until this is sorted out, I am prolly going back to CFP 2. And I do believe this is a CFP 3 problem, as I have 2 nearly identical machines (my main PC and my backup) - the exception is that one runs CFP 3 and one, CFP 2. I really hope you guys get this fixed - or determine it’s not a CFP problem, as I’m contemplating moving a bunch of machines from ZAP to CFP. Since usually I defrag and/or chkdsk frequently, such failures are unacceptable.

Thanks and good luck!

I think that the problem that I have had with chkdsk.exe is related to CFP. I am getting a failed reset of the registry resulting in the continual running of chkdsk.exe at startup. It also causes BSOD errors (Session5_initialization_failed) and a lack of chkdsk.exe progress screen (just the We’re sorry… screen with the boot options which does not disappear after the timer reaches 0 - just a lot of disk activity which I assume to be chkdsk.exe running.) Unfortunately, I did an image restore before I could use my computer again, so I don’t have the .dmp file for you, but the registry protection from CFP is the most likely culprit.

This is probably related to the Perfectdisk problems also.

Why are Comodo devs still waiting to launch a version that fixes this problem? (:SAD)

I’m still waiting for it to reinstall Comodo… pleeeeeeease! (:WIN)