Is there any way to tell Comodo not to ask ne 15 - 20 times about service.exe when I am doing an install or running WinUpdate>

All I do is sit here hitting the “Allow” choice – and it’s in “Installation Mode”

Chuck Billow

You have to choose Installer or updater on the alerts, for Installation Mode to work properly.


How did you enter installation mode? Did you enter it from the GUI, or did you tell it to enter installation mode by way of the popup by selecting “treat application as an installer/updater”?

The method you should be using is treat application as an installer/updater from the popup when you run an installer.

You also don’t mention which mode you are running in, but when doing Windows updates, you could put D+ in safe mode and it should just allow the updates to run with no prompting from you because Micro$oft is on the trusted vendor list. (assuming you haven’t removed it, or disabled the trusted vendor list)

I run both D+ and the firewall in safe mode using the Internet Security configuration. I’ve yet to see any alerts when running Windows update.

Edit: Ah, Dennis ninja’d me. :-[


I have Firewall and Defense+ in Safe mode. I am getting this when I am in “Installer” mode,which I choose o the first pop up. That works for everything but the services.exe alert.



This Topic might help.


Dennis, mine were set like that aleady…oh my, still popping up…