"Service State: Not Installed" (but it is... and running!) :/

So I installed Comodo Backup (v1.0.4.337) on my Vista Home Premium laptop and after restarting I get the message “Service Status: Not Installed” and so it wont do any of my service backups. :confused: But in going to Manage > Services not only is the service installed, it’s running… also, UAC is disabled…

I wrote tech support about it two days ago, but so far no reply…

Anyone have experience with this situation? I see some people having issues with the service, but nothing where the software says “not installed”… (see attachment showing message and service-status)

Thanks for any help!
-Dustin H

[attachment deleted by admin]

This seems to be a rare issue…(I haven’t seen it before). It could be something wrong with your installation, try reinstalling.

Been there… done that… didn’t work. :frowning: Uninstalled it, rebooted and reinstalled and had the same issue…

Uninstalled again, rebooted, and went through the registry looking for any obvious Comodo Backup keys but didnt see anything… one last re-install and still doesnt work.

No log files that I can submit?

Did enabling it in the Services list work?

Start > search “Services” > click “Services” > right click "ComodoBackupService > click "Start in the context window that pops up.

If that didn’t work, try reinstalling again, this time use Revo Uninstaller to uninstall.


I will try the Revo Uninstaller, but as I mentioned the service is already running and cycling the service from the Service menu doesnt have any effect… the Backup software still states “Service State: Not Installed”. :confused:

Honestly the only thing I see being left-behind after an uninstall is the Program Files folder with about three files in it… the registry is clean and I cant see any remnants of anything.

My plan is to…

  • uninstall it again; then reboot
  • delete all file remnants and obvious registry keys
  • use Comodo Registry Cleaner
  • reboot
  • reinstall - and see what happens

Pretty frustrating though… it’s nice to see the support on the forums versus the eMail support. They keep saying “The developer(s) will be getting back with me…”

I’ll post back with my results…

Yeah, I know things like that can be frustrating. Thinks about Windows Update problem (And tech support, well, no tech support has ever helped me.)

Remember to install in an admin account, and run as a admin (right click on CBU installer > click “Run as Admin…”).

Ugh - many attempt and it’s simply not working or getting any closer… I honestly just have poor experiences with Comodo wares and dropping them… sad really… final uninstall coming up…

I’m sorry that it isn’t working for you. :-\ Maybe you just need to find another backup program. Sometimes something can happening which keeps certain software from a company from working. (Like before I formatted any products from Sun Microsystems would never work.)

Could you post this in the Bug List topic? Thanks!

I have just encountered the same problem on an XP machine being run by a small charity. I installed Comodo Backup on the machine last week, tested it and i was fine. I tried to open it this morning and found that it would not open. When I managed to get it to display something (by right clicking and using run as) the service status was shown as “not installed” and it therefore refused to do anything. I have re-downloaded it and installed a couple of times but with no success. I have tried stopping and starting it in Services but still to no avail. To prove that the downloading was OK I installed it on another machine at the Charity but I am concerned about leaving the problem unresolved in case the same problem occurs with the second machine and the automatic backups that they thought were running, were, in fact not run.

Hi nately

This sounds like a problem with Backup install conflicting with some old registry settings. I suggest that you uninstall it and do a registry clean with a reputable cleaner like Comodo Registry Cleaner. If you do not like to use Reg Cleaners just look through the entries it finds for anything to do with Comodo Backup and remove only that.
After that try the install again and let us know if it is working for you.

I have been using Backup for almost 2 years and it never fails me. I set it and forget it.