Serious Vista System Restore problem

  • Your Operating System: Windows Vista Business 32bit
  • Security Software Installed: CIS, BOClean, Spyware Blaster, Super AntiSpyware, Malwarebytes AntiMalware
  • How you produced the problem: tried running System Restore, but found that it doesn’t work
  • How you tried to resolve the problem: ran System Restore in Safe Mode, but that didn’t solve the problem
  • Screen-shots with the error (if any): attached
  • Post Memory Dumps on crash if you encounter any: NA
  • All log files of CSC, if you had logs enabled: attached
  • Any other Additional Information;
    I update from within CSC version .33 to version .36 and ran the registry cleaner and then the disk cleaner. I didn’t pay attention to the Prefetch Application Cache problem and thought that it was fixed. I know this problem is actually fixed in version .37, but not in version .36. The Prefetch Application Cache option was still checked by default after updating from within the program, even though the release notes said that it was unchecked by default. I did not use the Safe Delete function because I normally don’t have any use for it and only use the CDC option to create a Restore Point. This has always been sufficient to fix any problems that CDC caused in the past.

After running the disk cleaner I found that the Windows Installer was still trying to install a Microsoft Office component. That is when I realized that the Prefetch Application Cache problem still existed. But when I tried to run System Restore, I found that now it was not working properly. I had not encountered this before, even when CDC ran with the Prefetch Application Cache checked. System Restore will open in Safe Mode without getting the RPC server message and it will run, but it won’t successfully restore the computer to the point prior to running CDC and fix this System Restore problem.

Does anyone have any idea how to repair System Restore, since CDC deleted prefetch files that it needs to work properly?

[attachment deleted by admin]

Ah RPC service has stopped working. You need RPC to run almost any task on your pc. All i can surgest is put your vista setup disk in, run the setup and select upgrade to give a clean install and keep all your files.

This is what i did when it happend it me way back when csc 1.0 was in its first beta.

When it happend to me nothing would open no programs not even the start menu would appear, is it the same with you?

No, all programs function properly except for the System Restore function in normal mode. I only have a Vista upgrade disk, since we got my wife’s laptop before Vista came out. I don’t think it has an upgrade option. other than to upgrade from XP, but I am not totally sure. I don’t want to install Vista back to its original state if I can help it. What is funny is that sometimes System Recovery pops up and appears as if it is going to work normally, but then a popup subsequently comes up showing the error message that I attached. I have searched for info on the RPC server, but didn’t find anything that related to this specific issue. Most articles were talking about the RPC server in relation to Windows Server 2003.

Vista Ultimate will boot to the screen that has ‘Repair My Computer’ as one of several options listed where you can go into Safe Mode, but Vista Business doesn’t list the ‘Repair My Computer’ option. I have downloaded and burned an ISO image of the Vista Recovery Disk to CD, so I can run the System Restore function from the Vista recovery options that this disk boots to. Booting to this Vista Recovery Disk, I ran a System Restore to the point prior to running CDC and it said that it completed successfully, but System Restore in normal mode still gives me the same error message that I was previously getting.

Oh I see why now I thought it said RPC Service on the print screen not RPC server.

You can try and see if someone can lend you a Vista set up disc or download one from a torrent (not illegal cus you own a valid Vista license), run the setup and choose the upgrade option to get a clean copy of Vista (With all your files and programs) put in your Vista Serial Number and it all should be back to normal.

I’ve done this in the past with peoples computers running Vista with problems like system restore, windows defender, windows sidebar not working and it has always fixed the problems.

Good Luck

Thanks for the info.


We tried to reproduce the System Restore RPC Server problem according to your scenario and many other aggressive ways on multiple platforms and operating systems, but everything performed properly. Even when we manually deleted registry entries related to RPC that could potentially be deleted by Registry Cleaner if found broken due to software deletion or other errors generated , the worse thing that happened was that CSC didn’t create the Restore Point anymore even when set to create one. But in normal operation mode ( without tampering with registry editor entries ) it worked as it’s supposed to, creating the restore point and successfully restoring it everytime.

Thank you for your support.

Thanks for your efforts. I don’t know exactly what caused this problem, but it seems to have solved itself. I uninstalled Comodo Internet Security .477 and installed CIS RC1 yesterday. After doing so, I was getting ready to run an upgrade with the OS installation disk to try to solve this System Restore problem. I decided to check and make sure that the problem still occurred and found that System Restore was working normally once again. I don’t think that this problem was related in any way to the CIS .477 installation that was on the computer, but who knows.