Seems Impossible To Re-Install

[b]Since I’m new to the forum … I’d like to say “Hello” to all Comodo Forum Users.
Here is my problem … hopefully someone can help/advise me:

I downloaded and installed a free home edition of CFW many months ago. All went well, except I seemed to have everything freezing up after installation. I became so frustrated with it, that I uninstalled it.
Since then, I have come across so many wonderful write-ups/opinions about CFW, that I just had to give it one more try. Everything (again) went smoothly … however, it seems impossible to install it. I keep getting a message, telling me to, “Go to ‘add/remove programs’ and uninstall it”. The problem is, I uninstalled it quite some time ago … it does not appear in my programs, nor in any of my files or folders.
Apart from my new download (downloaded yesterday) which (of course) I can’t install. (:SAD)
I have written to support explaining this problem, but was advised to try the forum for help.
Can anyone out there, HELP ME? … this is so frustrating!

Thank you … and “Have a good day!”[/b]

Hi there,

If it were me i’d try installing in safe mode to see if that works.

But i’m sure that either AOwl, Kail, Little Mac, or panic (to name a few) will be along shortly to give you their usual top notch adivce. ;D

Thank you Rucia. :slight_smile:


The original installer was MS Installer. This installer was determined to be… unfit for purpose (I’m being very polite ;D). So, Comodo replaced it with their own. But, I think that was in late October 2006. So, I guess what has happened is that some element of CPF might have been left behind and the new installer is detecting it. Did you have problems with the uninstall?

Also please check the Windows Event Log & see if there is any reported entry at the time you attempted to install CPF.

LittleMac, is our uninstall expert (he will not like that :D). I’ll also point him to this topic.


I searched the forums & discovered a topic where Egemen (CPF developer) asked another user to look for the following 3 registry keys…


… when the user couldn’t re-install following an abortive installation previously. If you’re familiar with the Registry, I’d like you to also search for these keys. Thanks.

[b]Thank you Rucia and Kail.

When it comes to designing/creating graphics and websites … I’m pretty good. When it comes to my computer’s system … I’m very hopeless, and I’m not familiar with the registry keys.
I’ll try to get a friend to help me with the advice you’ve given me, and get back when I’ve tried that.
By the way Kail … I’m sure the original version, I downloaded beginning to mid October, and I had no problem installing or UNinstalling it.
I agree with you … there must be something left behind it’s picking up on … if I could only find it.

Will let you know how I make out.

Thanks again guys.[/b]

Actually, Kail, IF I’m anything inasfar as uninstall expert, it would be for CAVS 1.1… :wink: But don’t worry, I’ll thank you later… (maybe some nosewool…heh heh) ;D

I’m sorry you’re having this hassle, PollyMD. If you haven’t already cleaned the registry out (or if you did and still no joy), you may try this:

Go to Start/Run, type in “cmd”. When the DOS window opens, you’ll type the following at the prompt (probably looks like “c:\documents and settings\username>” ) : “cd c:\program files\comodo\firewall” and press enter/return. This changes the command line directory to the default firewall install directory.

Then at the prompt (which is the filepath you just typed in), type “fwconfig -uninstall” and press enter.

It should prompt you when finished, and you can close the DOS window.

Then you can manually delete any folders/files left for the Comodo Firewall. The will be in the same filepath as you’ve typed in earlier; just follow that through your system (“My Computer” icon, or whatever you have).

Hope that helps.


[b]Thanks LM …

I followed your instructions and got “C:\Documents and Settings\ct>”
Continuing on and presssing enter, I got the message “is not recognized as an internal or external command, operable program or batch file”

After this, I manually went through files and found 3 folders for Comodo Firewall … they were empty, and I deleted them. I have 2 hard drives C: and E: These empty folders were found in C: My original download of CPF was downloaded to E:

I then downloaded the new version of CPF and tried to install that. It still comes up with “You seem to be having CF installed using older version of installer” and to go to Add/Remove programs.

I just don’t know what to try next. It’s a pity that the new installation just doesn’t over-ride these old files.

Any more suggestions?

Thanks for your help.


Download this zip file Comodo Forum unzip its files in C:\ and in the command line of windows type the follow command:
c:\fwconfig.exe -uninstalln

then reboot your pc.

ps. its the standalone uninstaller of CFP :wink:

[b]Hi Pandlouk,

Wish I could say, “All is resolved” … but that’s not the case.
I downloaded the zip file and unzipped it … no problem there.
Now, when you said, ‘the command line of windows’ were you telling me to go to ‘start’ then ‘run’? … shows how much I know … duh!

Anyway, that’s what I did, and had no success.
If I didn’t go to the right place … could you let me know where the command line of windows is exactly?
I’m not too swift when it comes to this side/end of things (:SAD)

I really appreciate all the help you can give me.

Thanks a bunch.