Security Monitoring

I have set it to custom, but all of the options (application/component monitor etc) are off, and can’t seem to be able to turn them back on.
Worked fine when it first installed, downloaded updates for it and since then problem has occured, any help would be greatly appreciated.

If you have made changes to the default settings
My recommendation would be
1)Back up Your network rules
You can Back up your network Control Rules if you are comfortable with using registry editor this
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall\NetCtrl
This only backs up your network Control Rules
NOTE: While all recommendeations have been tested. Editing the registry can be dangerous and neither COMODO nor The advisor takes any responsibility for damage that may be caused to your system while using registry editor
or you can use a script written by Rotty

Click here to download the file
2)Uninstall CFP
4)Restore your registy
4a. Make Sure CPf is not active on your PC. If it is Right click on CFP on your task bar and select “Exit”
4b. Locate a folder called CPFBackup on your desktop
4c. Open the folder.
4d. CLICK on the file called CPFRUles.REG
4e. When prompted " Are you sure you want to add the information … to the registry"
select 'Yes"
5)Reboot the PC

If you have not changed any of the default settings in CPF Simply uninstall and Reinstall

Note: the advisor is a volunteer and any advice is given strictly out of personal experience and/or research

When did you first install it, what version, etc? And when did the updates occur that it has been this way since?


Did you install it under an admin login and are you now using it under a limited user account?

Ewen :slight_smile:

I am having the same problems, I ran the file to modify the registerym but it did not correct the problem. I can not turn on the application monitor, component monitor. Everything is locked out. I have uninstalled the program many times. What did you do to fix the problem

If it has worked for you at some point, but then stopped, my suggestion would be to Turn Off/Disable any active security software (such as Antivirus, Antispyware, HIPS, registry protection, etc), physically disconnect your computer from the internet (such as unplugging the connection cord/cable) then uninstall CFP (using the built-in uninstaller) by going through Start/All Programs/Comodo/Firewall/Uninstall. Reboot.

Turn off all active security software again (or make sure it has stayed off after the reboot). Run a registry cleaner such as ccleaner or RegSeeker (both are free, and available for download through Be sure to utilize their built-in option to create a backup of the registry before deleting orphaned, unused, or otherwise unneeded entries. Reboot.

Once again make sure all active security software is turned off/disabled. Then reinstall CFP using the Automatic install mode (do not choose the ‘Manual’ or ‘Advanced’ install routine), and reboot. Reconnect the internet, and turn active security software back on. See if that helps.

On the other hand, if it has never worked for you, and always been this way, it may be an issue of OS compatibility. CFP does not at present (as of version 2.4)support anything other than 32Bit versions of Win XP, Win2K and Win2K3. If you’re using one of those and it’s never worked, then go through the steps above.