Security Center keeps showing Comodo is active

I’ve installed the latest version of Comodo Firewall, 3.0.18.309, and after uninstalling it keeps showing up as active in the Security Center. I’ve done exactly like this thread instructs us to, using the .bat file and then checking manually the files and registry, and even followed the advice forum member “pandlouk” instructed

a. At the command line of Windows XP [Start > Run] enter the command "CMD" (without the quotes) and press Enter. b. At the new Command Prompt window, type "NET STOP WINMGMT /Y" (without the quotes; there must be a space between WINMGMT and /Y) and press Enter. Then type "exit" end press Enter again. c. Go to the folder C:\WINDOWS\system32\wbem and delete the folder "Repository". d. Reboot. The Repository folder will be recreated automatically by the Security Center and will now display the correct information.

to no avail. It keeps showing up as active in the Security Center.

Please help, I don’t know what else to do.

I have Windows Home SP2 fully updated except for IE7 (I use Firefox).

Yes this is a problem that needs to get fixed, I hope Comodo doesn’t ignore this, I know that it happens to alot of users.

Easily fixable and its not just Comodo. Happens even with other firewalls and anti viruses. Simplely go to run. Type “services.msc”. Find the WMI service ( Windows Management Instrumentation ) and stop it. Then go to C\Windows\System32\Wbem and delete the repository folder then reboot.

Hi Follow these instructions :slight_smile:

How to Fix WMI components

Step 1: Register wmidcprv.dll

==========================

  1. Click Start, click Run, type “cmd” (without quotation marks) in the open box and click OK.

  2. Type in the following command and press Enter.

Regsvr32 %SystemRoot%\System32\wbem\wmidcprv.dll

You will receive a succeeded message.

Step 2: Register WMI components

==========================

  1. Please click Run, type “cmd” (without quotation marks) in the open box and click OK.

  2. Type the following commands one by one and press ENTER at the end of each command:

cd /d %windir%\system32\wbem

for %i in (*.dll) do RegSvr32 -s %i

for %i in (*.exe) do %i /RegServer

Note: If the Windows Management Instrumentation Tester window appears, this is normal; just proceed and close it.

Step 3: Reset Windows repository

1 Please click Run, type “cmd” (without quotation marks) in the open box and click OK.

  1. Type the following commands one by one and press ENTER at the end of each command:

net stop winmgmt

cd /d %windir%\system32\wbem

ren repository repository.old
(or delete it using the command “rd /s repository” instead of the ren command)

Step 4: Restart the computer

  1. Restart the computer and check whether the issue is resolved

LOL thats too much. Works like a charm my way.

Hi! Nope, it didn’t work, did exactly as you told and it still keeps showing Comodo as an active firewall. :frowning:

Do what I said.

Have a look at

https://forums.comodo.com/help_for_v2/rebuild_repository_folder_to_recognize_comodo_resolved-t2479.0.html;msg19751#msg19751

N.B. Slight correcton - you will need to reboot after you have deleted the repository to get it to rebuild.

Ewen :slight_smile:

I’m afraid both Vettetech and Panic methods didn’t work. :frowning: :frowning: :frowning: :frowning:

The batch file assumes English language version of Windows XP and appropriate folder locations and service names.

I’m guessing you’re Portugeuse or Brazilian. Are your folder names, service names and folder locations identical to what the batch file is expecting?

Cheers,
Ewen :slight_smile:

Portuguese. :slight_smile:

Yeap, they are identical, no differences at all from the English version.

Joan it works cause it happened to me last night. Stop the WMI service. Then delete the repository folder then reboot. Follow the steps I said exactly.Did you do a complete uninstall?

https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_3_info-t17220.0.html

Yeap, did exactly as you said, to the letter, and did exactly what was in that thread, using the .bat file then checking the files and registry manually to see if they were all deleted, which I presume is a complete uninstall, but it keeps showing Comodo active here. :frowning:

Odd! I just killed my repository with the batch file and let the OS rebuild it just to double check and it worked without an issue.

Are you running any other kind of security software that could prevent the deletion or do a restore on reboot?

Ewen :slight_smile:

Well, I have Spybot installed with Teatimer active, though I doubt it could be that. I also have system restore turned on by default, it came like that when XP was installed. I did the steps in this thread after I uninstalled Comodo and not installing anything else. It didn’t work though I didn’t notice that at the time, I just presumed it would work automatically for me, so I installed Online Armor Firewall. However I feel it may not be the firewall since I did the exact steps of the thread I just mentioned without any firewall installed and it didn’t work.

Still, I really have no idea what might causing XP to keep on recognising Comodo despite doing everything in this thread, it really is odd, it should have worked one way or the other.

I have to ask, other than security center saying there’s two firewalls on, does this problem has any other ramification? Does it ■■■■■ the computer in any way other than the security center just saying there’s two firewalls?

Are you able to delete the “repository” folder?

Yes I am, without any problems whatsoever.

Its odd. I uninstalled Comodo last night on my laptop and the Security Center still showed Comodo after reboot. I stopped the WMI service. Delete the Repository folder and reboot. When I was back up the Secuitry Center showed no firewall active.

If Teatimer monitors the repository (it is a possibility) it could prevent the deletion.

As a test, could you 1) temporarily disconnect from the internet (just to be safe), 2) temporarily disable TeaTimer, 3) temporarily disable System Restore, 4) rerun the batch file, 5) reboot (remembering to stay disconnected from the internet) and see if the alert about Comodo has gone.

Once you’ve check, re-enable TeaTimer and System Restore and reconnect to the internet.

I have to ask, other than security center saying there's two firewalls on, does this problem has any other ramification? Does it ■■■■■ the computer in any way other than the security center just saying there's two firewalls?

It shouldn’t be a problem, other than the alerts, but it shuldn’t happen either. :wink:

Ewen :slight_smile:

Yeah, it really is strange, because the steps in that thread you mentioned are enough to reset security center. And even if that doesn’t work then the steps cpf detailed would surely do the trick. However, none worked and it’s really odd.