Secure website loading slowly; turning off CFP helps [closed]

Hi everyone,
This is probably a weird question but I’ll ask anyway.
First some background - I’m an Avon rep and order online on Avon’s secure rep website. I’ve noticed that when I’ve logged into the website, it is unbelievably slow to move from page to page or to do any of my ordering. I tested it out by shutting down comodo and suddenly the website is as quick as any other I visit. It looks like the slowness is because of my firewall. Obviously I don’t want to be shutting down the firewall every time I have to work at the rep site.
So my question is: is there a way to enter the Avon rep site as a trusted url into Comodo.
I hope I’ve made some sense here.
Thanks in advance.
Sue

The thing to do would be check CFP’s activity/connections window while you’re on, to see how many open connections are established to that site (and how many other connections that site may have opened to others to add content to the page).

Also look in Activity/Logs to see if CFP has blocked something specific for traffic; the site may open some connections that are not allowed by your Network Monitor rules.

Rather than shutting down CFP, change the Security Level (temporarily) to Allow All to see if that works (it probably will). Also you might try turning the Network Monitor off to see if that speeds it up. These two things will just help us determine what’s slowing it down.

LM

PS: I’ve moved your post to the Help board, so we can address your question directly.

Thanks for the suggestions - I will try them this weekend and let you know what happens.
Sue

No problem, Sue. I’m not around the forum much over the weekend, but others are. I’m sure someone will step in to help you out. If not, I should be here no later than Monday…

LM

I checked the Activity/Connections window and found there are many connections are established to the site. I’m not sure how to tell “how many other connections that site may have opened to others to add content to the page”

Also, I changed the security level from custom to allow all - and found the site much faster. But obviously I prefer not to “allow all”. Right now it’s left on Custom.

Now that I know the IP for the site, would it be advisable to add this ip address to Network Monitor / Network Control Rules to allow the site.

Thanks in advance for any thoughts - I won’t be available until Wednesday, but will check back here as soon as I can.

Sue

Sue,

Changing the Security Level to Allow All is something we’re doing only for diagnostic purposes; you are right not to leave it that way. Since doing so loads the site much faster, that tells us that your issue is one of Rules; and most likely Network Monitor…

Here’s what I’d like you to do at this point:

  1. Open Activity/Logs. Right-click an entry and select “Clear all logs.”
  2. Immediately open the Avon site and log in and go thru the motions of placing an order (get a couple pages into it, so as to generate some log entries. (you don’t have to complete an order)
  3. Open Activity/Logs. Right-click an entry and select “Export to HTML.” Save the file.
  4. Reopen the file (it will open in a browser window). Highlight the entries, right-click and Copy.
  5. Paste into your next post. If your external IP address shows in the logs (it will match the IP showing in the lower right corner of your posts here), you may mask it out with “x” for privacy (such as xx.xxx.xxx.24)

Note: if there are more than about 6 entries, instead of copy/paste, re-save the .html file as a text file (change the extension to “.txt”) and attach to your post under “Additional Options.”

LM

Hi LM,

Sorry I couldn’t get back to this until this morning.

I opened Activity/Logs, then right clicked and clicked on ‘clear all logs’, then I went to the rep site and logged in and went through the motions of adding products to my order etc. I did spend a fair amount of time on the site, doing all but submitting my order. When I went back to Activity/Logs - there was nothing there!!! I did leave the Activity/Logs page open when I logged in etc - should I have closed the Activity/Logs page? Really don’t understand why nothing appeared under logs.

I’ll try it again - just let me know if I had done something wrong.

Thanks,
Sue

No, you don’t have to leave the Logs page open, Sue. If it’s not logging, then it’s probably not blocking anything. Try doing these things, each one at a time, while navigating thru the process or placing an order.

Open Network Monitor, click the “Turn Off” option at the top. See if that speeds things up. If it does, post back with that (and turn it back On). If it doesn’t speed it up, turn it back On and go to the next one.

Open Application Monitor, click “Turn Off.” See what your results are (you don’t have to log out or anything; you can switch these while you’re doing your order). If it’s good, then turn it On and post back. If not, turn it On and go to the next one.

Open Security/Advanced/Advanced Attack Detection & Prevention/Miscellaneous. Uncheck “DO protocol analysis.” Click OK. See what your results are. Whichever way it goes, re-enable protocol analysis and post back.

Then we’ll see what’s next. Hope that makes sense. If you have any questions, just ask.

LM

Hi LM,

Thanks for additional suggestions to try. I will work on it on Tuesday - long weekend here - and will report back any results.

Thanks again for all your help and if you get a long weekend where you are, have a good one.
Sue

No problem, just let me know how it goes.

You must be a week ahead in your time zone… my long weekend isn’t for another week, yet. :wink:

LM

Hi LM,

Just want to apologize for the delay reporting back results of your suggestions. Had to install a new motherboard over the weekend - still not totally up and running. Will hopefully get to the slow secure website issue and your suggestions by the end of the week. But just wanted to let you know what the delay was.

By the way, I’m in Canada - this past Monday was Victoria Day (Queen’s Birthday) hence the long weekend.

Sue

Ah, no problem, Sue. Get the motherboard fixed, everything back up and running, then worry about the small stuff… :slight_smile:

Our long weekend coming up is Memorial Day, wherein we “remember” those in the military who have given their lives in defense of country. Mostly, we probably just are glad to have a paid day off, and care nothing for the military, but that’s the stated intent and purpose of the day. Would that it were truly celebrated for what it signifies. :frowning:

LM

Hi LM,

First let me apologize for the long delay before getting back to you. I also want to say I appreciate all your help and suggestions.

I decided to download and install the latest Comodo Firewall (2.4.18.184). I guess it is a combination of new, faster motherboard (2.40GHz) and latest Comodo Firewall, but I am no longer having a problem with the Avon rep secure website being slow! Now it is just as fast as any other site I regularly visit.

I have kept all your suggestions, in case I run into another problem. And again want to thank you for all your help.

All the best,
Sue

No problem, Sue. Given that outcome, it’s possible that something went ‘south’ on your first/previous install and caused a functional problem somewhere (which wouldn’t show up on logs, etc) that was interfering.

I’ll go ahead and close out the topic. If you do need it reopened, just PM a Moderator (be sure to include a link to this thread) and we’ll be glad to do so.

LM